aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-21 20:39:35 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-10-24 01:48:22 +0500
commitff7f99366c423cf1e3957096cf1fb831bb2581d2 (patch)
tree5a2efe7a7dca91f26303817da23e1ba7ea343f72 /dev-python/celery
parentdev-python/pytest-click: new package, add 1.1.0 (diff)
downloadguru-ff7f99366c423cf1e3957096cf1fb831bb2581d2.tar.gz
guru-ff7f99366c423cf1e3957096cf1fb831bb2581d2.tar.bz2
guru-ff7f99366c423cf1e3957096cf1fb831bb2581d2.zip
dev-python/celery: add 5.3.0_beta1, drop 5.2.6
Closes: https://bugs.gentoo.org/859769 Closes: https://bugs.gentoo.org/841970 Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/Manifest2
-rw-r--r--dev-python/celery/celery-5.3.0_beta1.ebuild (renamed from dev-python/celery/celery-5.2.6.ebuild)57
-rw-r--r--dev-python/celery/files/celery.initd-r251
3 files changed, 61 insertions, 49 deletions
diff --git a/dev-python/celery/Manifest b/dev-python/celery/Manifest
index ef4f9c17e..e5bf84e1d 100644
--- a/dev-python/celery/Manifest
+++ b/dev-python/celery/Manifest
@@ -1 +1 @@
-DIST celery-5.2.6.tar.gz 1490948 BLAKE2B 1470b74b5d9345ddbb466ec83e684c71fd999fb9671be8a99c795d82ee53a45a5ec5e5c383104933ef2359b655043c408eef8de7dce7c5327a42b7d978a0b711 SHA512 80565cee3ac20a4a28e64582bd2a8cd807980447254d5cbad41c9954a012c025c402c5113d9610f879e74bf170ae7e3c70b5a3ace7228ae510feee380b9b48f9
+DIST celery-5.3.0_beta1.gh.tar.gz 1509819 BLAKE2B 8864d9895823fde8ed1938a8b418906e624f14f6d306f1afb54bfc3c1897facfb22a85e368b2fb3ac96992d639e5f03589bfc78488de9ce060c88d9d1321e4ab SHA512 c617a03ca85120b7889eb94b36e41b3ba45b93acfe239c56c93b0860042a06fceaad1c396342e27f941ae58fd3d7468bf22d6b042b04e246b55abe5eedb63016
diff --git a/dev-python/celery/celery-5.2.6.ebuild b/dev-python/celery/celery-5.3.0_beta1.ebuild
index 0b047820e..0075e42b3 100644
--- a/dev-python/celery/celery-5.2.6.ebuild
+++ b/dev-python/celery/celery-5.3.0_beta1.ebuild
@@ -4,47 +4,53 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-MYPV="${PV/_beta/b}"
-PYTHON_COMPAT=( python3_{8..9} )
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1 optfeature
+MY_PV="${PV/_beta/b}"
DESCRIPTION="Asynchronous task queue/job queue based on distributed message passing"
HOMEPAGE="
https://docs.celeryproject.org/en/stable/index.html
https://pypi.org/project/celery/
https://github.com/celery/celery
"
-SRC_URI="https://github.com/celery/celery/archive/v${MYPV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MYPV}"
+SRC_URI="https://github.com/celery/celery/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-# There are a number of other optional 'extras'
IUSE="examples"
-#RESTRICT="!test? ( test )"
-RESTRICT="test" # 'celery' not found in `markers` configuration option
RDEPEND="
>=dev-python/billiard-3.6.4.0[${PYTHON_USEDEP}]
- <dev-python/billiard-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/billiard-5.0.0[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-didyoumean[${PYTHON_USEDEP}]
+ dev-python/click-plugins[${PYTHON_USEDEP}]
+ dev-python/click-repl[${PYTHON_USEDEP}]
+ >=dev-python/kombu-5.3.0_beta1[${PYTHON_USEDEP}]
<dev-python/kombu-6.0.0[${PYTHON_USEDEP}]
- >=dev-python/kombu-5.2.1[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/vine[${PYTHON_USEDEP}]
"
-DEPEND="
- ${RDEPEND}
+BDEPEND="
test? (
+ $(python_gen_impl_dep 'ncurses(+)')
>=dev-python/boto3-1.9.178[${PYTHON_USEDEP}]
- >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
+ dev-python/elasticsearch-py[${PYTHON_USEDEP}]
>=dev-python/moto-1.3.7[${PYTHON_USEDEP}]
- >=dev-python/pytest-6.2[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
dev-python/pytest-celery[${PYTHON_USEDEP}]
+ dev-python/pytest-click[${PYTHON_USEDEP}]
dev-python/pytest-subtests[${PYTHON_USEDEP}]
>=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
)
doc? (
dev-python/docutils[${PYTHON_USEDEP}]
@@ -55,9 +61,18 @@ DEPEND="
)
"
-# testsuite needs it own source
-DISTUTILS_IN_SOURCE_BUILD=1
+EPYTEST_DESELECT=(
+ t/unit/tasks/test_result.py::test_EagerResult::test_wait_raises
+ t/unit/tasks/test_tasks.py::test_task_retries
+ t/unit/tasks/test_tasks.py::test_apply_task::test_apply
+ t/unit/utils/test_collections.py::test_ExceptionInfo::test_exception_info
+ t/unit/worker/test_request.py::test_trace_task::test_execute_jail_failure
+ t/unit/worker/test_request.py::test_Request
+ t/unit/worker/test_request.py::test_create_request_class::test_on_success__SystemExit
+)
+
distutils_enable_tests pytest
+
distutils_enable_sphinx docs --no-autodoc
python_install_all() {
@@ -68,7 +83,7 @@ python_install_all() {
if use examples; then
docinto examples
dodoc -r examples/.
- docompress -x "/usr/share/doc/${PF}/examples"
+ docompress -x /usr/share/doc/${PF}/examples
fi
newbashcomp extra/bash-completion/celery.bash "${PN}"
@@ -77,16 +92,14 @@ python_install_all() {
}
pkg_postinst() {
- optfeature "zookeeper support" dev-python/kazoo
optfeature "msgpack support" dev-python/msgpack
#optfeature "rabbitmq support" dev-python/librabbitmq
#optfeature "slmq support" dev-python/softlayer_messaging
- optfeature "eventlet support" dev-python/eventlet
#optfeature "couchbase support" dev-python/couchbase
- optfeature "redis support" dev-db/redis dev-python/redis-py
+ optfeature "redis support" dev-python/redis-py
optfeature "gevent support" dev-python/gevent
optfeature "auth support" dev-python/pyopenssl
- optfeature "pyro support" dev-python/pyro:4
+ optfeature "pyro support" dev-python/Pyro4
optfeature "yaml support" dev-python/pyyaml
optfeature "memcache support" dev-python/pylibmc
optfeature "mongodb support" dev-python/pymongo
diff --git a/dev-python/celery/files/celery.initd-r2 b/dev-python/celery/files/celery.initd-r2
index 3789dc016..91dd838a6 100644
--- a/dev-python/celery/files/celery.initd-r2
+++ b/dev-python/celery/files/celery.initd-r2
@@ -9,31 +9,30 @@ depend() {
use rabbitmq redis logger dns
}
-CELERYD_ENABLED=${CELERYD_ENABLED:-"no"}
-CELERYD_PID_FILE=${CELERYD_PID_FILE:-"/run/celery/celeryd@%n.pid"}
-CELERYD_LOG_FILE=${CELERYD_LOG_FILE:-"/var/log/celery/celeryd@%n.log"}
-CELERYD_LOG_LEVEL=${CELERYD_LOG_LEVEL:-"INFO"}
-CELERYD_NODES=${CELERYD_NODES:-"celery"}
+: ${CELERYD_ENABLED:="no"}
+: ${CELERYD_PID_FILE:="/run/celery/celeryd@%n.pid"}
+: ${CELERYD_LOG_FILE:="/var/log/celery/celeryd@%n.log"}
+: ${CELERYD_LOG_LEVEL:="INFO"}
+: ${CELERYD_NODES:="celery"}
-CELERYBEAT_ENABLED=${CELERYBEAT_ENABLED:-"no"}
-CELERYBEAT_PID_FILE=${CELERYBEAT_PID_FILE:-"/run/celery/celerybeat.pid"}
-CELERYBEAT_LOG_FILE=${CELERYBEAT_LOG_FILE:-"/var/log/celery/celerybeat.log"}
-CELERYBEAT_LOG_LEVEL=${CELERYBEAT_LOG_LEVEL:-"INFO"}
+${CELERYBEAT_ENABLED:="no"}
+${CELERYBEAT_PID_FILE:="/run/celery/celerybeat.pid"}
+${CELERYBEAT_LOG_FILE:="/var/log/celery/celerybeat.log"}
+${CELERYBEAT_LOG_LEVEL:="INFO"}
export CELERY_LOADER
-CELERYD_MULTI=${CELERYD_MULTI:-"celery multi"}
-CELERYCTL=${CELERYCTL:-"celery"}
-CELERYBEAT=${CELERYBEAT:-"celery beat"}
+: ${CELERYD_MULTI:="celery multi"}
+: ${CELERYCTL:="celery"}
+: ${CELERYBEAT:="celery beat"}
-CELERYD_OPTS="${CELERYD_OPTS}"
CELERYBEAT_OPTS="${CELERYBEAT_OPTS} -f ${CELERYBEAT_LOG_FILE} -l ${CELERYBEAT_LOG_LEVEL}"
create_dirs() {
- local logfile="${1}"
- local pidfile="${2}"
- local logdir=$(dirname ${logfile})
- local piddir=$(dirname ${pidfile})
+ logfile="${1}"
+ pidfile="${2}"
+ logdir=$(dirname ${logfile})
+ piddir=$(dirname ${pidfile})
checkpath -d -q -m 0750 -o ${CELERY_USER:-"root"}:${CELERY_GROUP:-"root"} ${logdir} ${piddir}
}
@@ -66,9 +65,9 @@ celery_chdir() {
}
wait_pid () {
- local pidfile=${1}
- local timeout=${STOPTIMEOUT:-"10"}
- local PID=$(cat "${pidfile}" 2>/dev/null)
+ pidfile=${1}
+ timeout=${STOPTIMEOUT:-"10"}
+ PID=$(cat "${pidfile}" 2>/dev/null)
while [ -n "${PID}" ] && [ "${timeout}" -ge 1 ]; do
kill -0 ${PID} 2>/dev/null || break
@@ -96,14 +95,14 @@ start_workers() {
stop_workers() {
yesno "${CELERYD_ENABLED}" || return 0
- local timeout=${STOPTIMEOUT:-"10"}
+ timeout=${STOPTIMEOUT:-"10"}
${CELERYD_MULTI} stop ${CELERYD_NODES} --pidfile="${CELERYD_PID_FILE}" || return 1
# Wait for each node
for node in ${CELERYD_NODES}; do
- local pidfile=${CELERYD_PID_FILE/\%n/${node}}
- local PID=$(cat "${pidfile}" 2>/dev/null)
+ pidfile=$(echo "${CELERYD_PID_FILE}" | sed "s/%n/${node}/g")
+ PID=$(cat "${pidfile}" 2>/dev/null)
while [ -n "${PID}" ] && [ "${timeout}" -ge 1 ]; do
kill -0 ${PID} 2>/dev/null || break
timeout=$((${timeout} - 1))
@@ -150,7 +149,7 @@ stop_beat() {
start() {
- local cr=0
+ cr=0
checkconfig || return 1
@@ -166,7 +165,7 @@ start() {
}
stop() {
- local cr=0
+ cr=0
checkconfig || return 1
@@ -182,7 +181,7 @@ stop() {
}
reload() {
- local cr=0
+ cr=0
checkconfig || return 1