aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-10-08 13:10:06 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-10-08 13:22:06 +0200
commitc16888072b192fb39f1b1d6436a9e06a6fa67adc (patch)
tree40bd11d6898d352545d93682a2447a89606bcb99 /dev-libs
parentgui-libs/power-profiles-daemon: change maintainer in metadata.xml (diff)
downloadguru-c16888072b192fb39f1b1d6436a9e06a6fa67adc.tar.gz
guru-c16888072b192fb39f1b1d6436a9e06a6fa67adc.tar.bz2
guru-c16888072b192fb39f1b1d6436a9e06a6fa67adc.zip
dev-libs/olm: add 3.2.13
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/olm/Manifest1
-rw-r--r--dev-libs/olm/olm-3.2.13.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/olm/Manifest b/dev-libs/olm/Manifest
index 6b464a7a2..4c0540ff4 100644
--- a/dev-libs/olm/Manifest
+++ b/dev-libs/olm/Manifest
@@ -1,2 +1,3 @@
DIST olm-3.2.11.tar.bz2 2735303 BLAKE2B 577465d5a5246cda85848e0caa2912bd225af520c23a247cacec06669bae2ab0b7c3bf209a203e8bf2f7e0e573f7f30f8699704a2b6cf2e7996209eade69bb8c SHA512 4ab2263395efd33ecb336577d72845c8eaf6f6478448d78f104424ea7f48f6273e13df4038f96a05e946dbe5f6beb952bbbc86b81eaca035195dbdaaf9a2dd26
DIST olm-3.2.12.tar.bz2 2742680 BLAKE2B 47c3bacaf05cc0bb6088da34e6a031f9c770893771ddcf9f13bc0e10a050139f14969dfc91f38684336872089b4cbf9d66e4bd85692989eba5fc3df966da3cd2 SHA512 a25db4c72910512beca9120db59ebeeefc5fff6a381e88ae7cf261bc5ab896edc2cfe25ece57b7b28b2e3d8bc66367c457133c147e1a3514f926714159b5cf6f
+DIST olm-3.2.13.tar.bz2 2742762 BLAKE2B 8c18fbcfe53b414f33f567d337e7b30dd1f358b0d7aee55738ff5461b926967fa5c0c172311b017a8c05ecbce5cce22b4b4c69c8cad4c947d19eea7f9262661b SHA512 e6d386644f800710afc5a641d6a3a619b193f08cbe31495c6978446e71e3f38ca6a0aab9fff18725c653723c07755467b8785062bf2cbfef8a4f68406f73e4f3
diff --git a/dev-libs/olm/olm-3.2.13.ebuild b/dev-libs/olm/olm-3.2.13.ebuild
new file mode 100644
index 000000000..19d31a4cd
--- /dev/null
+++ b/dev-libs/olm/olm-3.2.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Implementation of the olm and megolm cryptographic ratchets"
+HOMEPAGE="https://gitlab.matrix.org/matrix-org/olm"
+SRC_URI="https://gitlab.matrix.org/matrix-org/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DOLM_TESTS="$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}
+
+src_install() {
+ use doc && DOCS=( README.md docs/{{,meg}olm,signing}.md )
+
+ cmake_src_install
+}