aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2024-04-27 20:06:30 +0200
committerLucio Sauer <watermanpaint@posteo.net>2024-04-27 20:29:50 +0200
commit094236653cbe196a6e2e0bd82113befef9f04e07 (patch)
treebbbe57da0b5b3dd277102fcbf445158cf4a59296 /dev-libs/ls-hpack
parentwww-client/yandex-browser: 24.4.1.915_p1 ver bump (drop 24.1.1.940_p1) (diff)
downloadguru-094236653cbe196a6e2e0bd82113befef9f04e07.tar.gz
guru-094236653cbe196a6e2e0bd82113befef9f04e07.tar.bz2
guru-094236653cbe196a6e2e0bd82113befef9f04e07.zip
dev-libs/ls-hpack: fix EbuildUnquotedVariablesCheck
Use simpler query and install functions Add suffix to GitHub-generated archive Bump copyright Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-libs/ls-hpack')
-rw-r--r--dev-libs/ls-hpack/Manifest4
-rw-r--r--dev-libs/ls-hpack/ls-hpack-2.3.0-r1.ebuild14
-rw-r--r--dev-libs/ls-hpack/ls-hpack-2.3.3.ebuild12
3 files changed, 11 insertions, 19 deletions
diff --git a/dev-libs/ls-hpack/Manifest b/dev-libs/ls-hpack/Manifest
index efc11640b..40345b6e0 100644
--- a/dev-libs/ls-hpack/Manifest
+++ b/dev-libs/ls-hpack/Manifest
@@ -1,2 +1,2 @@
-DIST ls-hpack-2.3.0.tar.gz 954741 BLAKE2B d93494c5d3e08c13e496021467b4984400739168916389e72def3f8619ddd056a73b01121453905376ac20935d7f05b8732ace9290345d0558a7ccc1b266d04d SHA512 45866b18042125cbbd008eed2935a938a42e1682030aa52ff4a324ddbad7bf9bd483161352cc8988bae668e132ee8b4b043ddc09d9e0316a66aaefd927ae2d76
-DIST ls-hpack-2.3.3.tar.gz 952559 BLAKE2B 18240d2f53524f3db0d18c76dc2ead041f1a3b7a0cff242610e9aab4d335a1b3bcecdc10f887805ae924caf2fb50db5ec53a05cd3ba521402e59d378d185fdfd SHA512 157af5f0bc31f77b18fd806d27a9483c79254c360ee5cc7a16617b86df6a1024a268215a49f459f31ac06fa4c9b03a8c0e6d999bfe6c90548e2fd8ccd3d9b54d
+DIST ls-hpack-2.3.0.gh.tar.gz 954741 BLAKE2B d93494c5d3e08c13e496021467b4984400739168916389e72def3f8619ddd056a73b01121453905376ac20935d7f05b8732ace9290345d0558a7ccc1b266d04d SHA512 45866b18042125cbbd008eed2935a938a42e1682030aa52ff4a324ddbad7bf9bd483161352cc8988bae668e132ee8b4b043ddc09d9e0316a66aaefd927ae2d76
+DIST ls-hpack-2.3.3.gh.tar.gz 952559 BLAKE2B 18240d2f53524f3db0d18c76dc2ead041f1a3b7a0cff242610e9aab4d335a1b3bcecdc10f887805ae924caf2fb50db5ec53a05cd3ba521402e59d378d185fdfd SHA512 157af5f0bc31f77b18fd806d27a9483c79254c360ee5cc7a16617b86df6a1024a268215a49f459f31ac06fa4c9b03a8c0e6d999bfe6c90548e2fd8ccd3d9b54d
diff --git a/dev-libs/ls-hpack/ls-hpack-2.3.0-r1.ebuild b/dev-libs/ls-hpack/ls-hpack-2.3.0-r1.ebuild
index 59695af8e..501ab4d7f 100644
--- a/dev-libs/ls-hpack/ls-hpack-2.3.0-r1.ebuild
+++ b/dev-libs/ls-hpack/ls-hpack-2.3.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ inherit cmake
DESCRIPTION="QPACK compression library for use with HTTP/3"
HOMEPAGE="https://github.com/litespeedtech/ls-hpack/"
-SRC_URI="https://github.com/litespeedtech/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/litespeedtech/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -27,12 +27,8 @@ src_configure() {
}
src_install() {
- cp ${S}_build/libls-hpack.* ${S} || die
- newheader lshpack.h lshpack.h
- if [[ $(usex static-libs) == "yes" ]] ; then
- newlib.a libls-hpack.a libls-hpack.a
- else
- newlib.so libls-hpack.so libls-hpack.so
- fi
+ local LIB_TYPE=$(usex static-libs a so)
+ doheader lshpack.h
+ dolib.${LIB_TYPE} "${BUILD_DIR}"/libls-hpack.${LIB_TYPE}
einstalldocs
}
diff --git a/dev-libs/ls-hpack/ls-hpack-2.3.3.ebuild b/dev-libs/ls-hpack/ls-hpack-2.3.3.ebuild
index 59695af8e..ddb4bea06 100644
--- a/dev-libs/ls-hpack/ls-hpack-2.3.3.ebuild
+++ b/dev-libs/ls-hpack/ls-hpack-2.3.3.ebuild
@@ -7,7 +7,7 @@ inherit cmake
DESCRIPTION="QPACK compression library for use with HTTP/3"
HOMEPAGE="https://github.com/litespeedtech/ls-hpack/"
-SRC_URI="https://github.com/litespeedtech/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/litespeedtech/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -27,12 +27,8 @@ src_configure() {
}
src_install() {
- cp ${S}_build/libls-hpack.* ${S} || die
- newheader lshpack.h lshpack.h
- if [[ $(usex static-libs) == "yes" ]] ; then
- newlib.a libls-hpack.a libls-hpack.a
- else
- newlib.so libls-hpack.so libls-hpack.so
- fi
+ local LIB_TYPE=$(usex static-libs a so)
+ doheader lshpack.h
+ dolib.${LIB_TYPE} "${BUILD_DIR}"/libls-hpack.${LIB_TYPE}
einstalldocs
}