aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Greener <dev@greener.sh>2024-04-18 20:20:58 +0100
committerRobert Greener <dev@greener.sh>2024-04-18 20:25:23 +0100
commit13d82c93ee97751829cb604b9ca0d91c95a2301a (patch)
tree8e1b73bede0b8276b0ff8259bca556dd5cf141e4 /dev-java
parentdev-java/corretto-bin: Remove redundant revision 8.402.08.1-r3 (diff)
downloadguru-13d82c93ee97751829cb604b9ca0d91c95a2301a.tar.gz
guru-13d82c93ee97751829cb604b9ca0d91c95a2301a.tar.bz2
guru-13d82c93ee97751829cb604b9ca0d91c95a2301a.zip
dev-java/corretto-bin: version 11.0.22.7.1 fix QA issues
Signed-off-by: Robert Greener <dev@greener.sh>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/corretto-bin/corretto-bin-11.0.22.7.1.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-java/corretto-bin/corretto-bin-11.0.22.7.1.ebuild b/dev-java/corretto-bin/corretto-bin-11.0.22.7.1.ebuild
index 8305000c2..3a3a6a4a0 100644
--- a/dev-java/corretto-bin/corretto-bin-11.0.22.7.1.ebuild
+++ b/dev-java/corretto-bin/corretto-bin-11.0.22.7.1.ebuild
@@ -6,15 +6,16 @@ EAPI=8
inherit java-vm-2 toolchain-funcs
MY_PV=${PV/_p/+}
-SLOT=$(ver_cut 1)
+DESCRIPTION="Prebuilt Java JDK binaries provided by Amazon Web Services"
+HOMEPAGE="https://aws.amazon.com/corretto"
SRC_URI="
- https://corretto.aws/downloads/resources/${PV}/amazon-corretto-${PV}-linux-x64.tar.gz
+ https://corretto.aws/downloads/resources/${PV}/amazon-corretto-${PV}-linux-x64.tar.gz
"
-DESCRIPTION="Prebuilt Java JDK binaries provided by Amazon Web Services"
-HOMEPAGE="https://aws.amazon.com/corretto"
+S="${WORKDIR}/amazon-corretto-${MY_PV}-linux-x64"
LICENSE="GPL-2-with-classpath-exception"
+SLOT=$(ver_cut 1)
KEYWORDS="~amd64"
IUSE="alsa cups headless-awt selinux source"
@@ -42,8 +43,6 @@ RDEPEND="
RESTRICT="preserve-libs splitdebug"
QA_PREBUILT="*"
-S="${WORKDIR}/amazon-corretto-${MY_PV}-linux-x64"
-
pkg_pretend() {
if [[ "$(tc-is-softfloat)" != "no" ]]; then
die "These binaries require a hardfloat system."
@@ -88,4 +87,4 @@ src_install() {
pkg_postinst() {
java-vm-2_pkg_postinst
-} \ No newline at end of file
+}