aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2025-02-08 20:55:28 +0100
committerFilip Kobierski <fkobi@pm.me>2025-02-08 21:14:20 +0100
commit5a441170d7fc87595cc9aef681a8e86151f3a93d (patch)
treef3252ea8ba4608061a1dd385b097c5e970d19aa8 /app-misc
parentnet-misc/qmodbus: add qmodbus 0.3.0 (diff)
downloadguru-5a441170d7fc87595cc9aef681a8e86151f3a93d.tar.gz
guru-5a441170d7fc87595cc9aef681a8e86151f3a93d.tar.bz2
guru-5a441170d7fc87595cc9aef681a8e86151f3a93d.zip
app-misc/nwg-look: add 1.0.2
Tarballs also used in slackware - update DESCRIPTION - sort INHERITs - add & use DOCS - make src_install mimic upstream's Closes: https://bugs.gentoo.org/949200 Signed-off-by: Filip Kobierski <fkobi@pm.me>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/nwg-look/Manifest2
-rw-r--r--app-misc/nwg-look/nwg-look-1.0.2.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/app-misc/nwg-look/Manifest b/app-misc/nwg-look/Manifest
index 091f8de73..f92003d80 100644
--- a/app-misc/nwg-look/Manifest
+++ b/app-misc/nwg-look/Manifest
@@ -2,3 +2,5 @@ DIST nwg-look-0.2.4-vendor.tar.xz 661292 BLAKE2B efc7b0083af61ac5dc21ecfc58feb91
DIST nwg-look-0.2.4.tar.gz 23389 BLAKE2B 3b036acd265b3b3defe2ba56388d8c5909047054b34a16c140f8b30e529d93214b4094d5f077a8cd80282b5f00dfde6f7f59de44e2a36bae5cc2749a207d6ee4 SHA512 8fd6521ebbabb7f0843da54e5dd02afc89c2a1f366c3c5d4317e434c465179ee9ada4ca4d602e5a0a21aa4624dda7b0eb880eb09f311ae4c4b55ad263757eff5
DIST nwg-look-0.2.5-vendor.tar.xz 661736 BLAKE2B de880226784f6aba90901d163a51312fd0db3f3ad11c1733e372d605a1772d6383acb64594b4f162a00da8685eec2ec5bc270b73f627ef7f5ca1cd5c722dbf3f SHA512 f1b24400dbfda7697f416f085a6c87056a9065365e5dce96292afed4086c1285d6d5e4da632504b0a87a08742948c045e599e62efc671c4618d6c826a15005f3
DIST nwg-look-0.2.5.tar.gz 23524 BLAKE2B 6e0ac8795dd3e630320837c2a22d3f8b40e2858c2c55c6e0a48f36530c557d42d7d011293f9ab700d8366e0fab574572da36072e37ffbca9db90459bd0e78159 SHA512 1e293ebf692bd9aebd2afaf35b43189d7db2640bf78c94d4393af2f948879a44f0bd6e70f5f346ca821c3da01d6415274d746a7c15901bdfeebe883fac18ea83
+DIST nwg-look-1.0.2.tar.gz 25237 BLAKE2B f165809395e661048ab5637458f05d05da69d8f66a394060e610478c49d0b9e0a8d69fa55b0a15ed38078fdeaf3eacc3b53a333659daeb57fc57813fd0e81b06 SHA512 dcc184c9079c78f484c786c54ac8672f178cfd792b08de97081b0ee80f80856235436a9b995e6fa348e24c3184d9ab1956357f41ba3e99719c76ead82824e1f5
+DIST nwg-look-vendor-1.0.2.tar.xz 702052 BLAKE2B 4b945ca5541491a4a244498a47296b533e60dce23120170d04dcda0f7f0c43c62ef2fd8892ec106ca1d2753b36cb4e64a7f2a0fcd8fdfef894fed9329eb22d90 SHA512 d8f9ef26fbc39aa7256d78c00652b59c2b5a41e40955037b31db8372f03c68838bbbf3f8679112bd2e215bb0e171c05c9c2ba96f0dc12ae52753c9430b3aa0c1
diff --git a/app-misc/nwg-look/nwg-look-1.0.2.ebuild b/app-misc/nwg-look/nwg-look-1.0.2.ebuild
new file mode 100644
index 000000000..ca30ced08
--- /dev/null
+++ b/app-misc/nwg-look/nwg-look-1.0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="GTK settings editor adapted to work on wlroots-based compositors"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-look"
+SRC_URI="
+ https://github.com/nwg-piotr/nwg-look/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://slackware.lngn.net/pub/source/nwg-look/${PN}-vendor-${PV}.tar.xz
+"
+
+inherit desktop go-module xdg
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/glib
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/harfbuzz
+ x11-apps/xcur2png
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.md )
+
+src_prepare() {
+ mv -v ../vendor ./ || die
+ default
+}
+src_compile() {
+ ego build
+}
+
+src_install() {
+ insinto /usr/share/nwg-look
+ doins stuff/main.glade
+ doins -r langs
+
+ insinto /usr/share/pixmaps
+ doins stuff/nwg-look.svg
+
+ domenu stuff/nwg-look.desktop
+
+ dobin nwg-look
+
+ einstalldocs
+}