aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-07-20 14:05:29 -0400
committerChristopher Fore <csfore@posteo.net>2024-07-20 14:05:29 -0400
commit1be68cda06ad6813184ce84b5455c8d52cc52603 (patch)
tree7476f858852d7062d46022628e29c2afe6f63f6a /app-misc
parentprofiles: mask www-apps/wiki-js-bin for removal (diff)
downloadguru-1be68cda06ad6813184ce84b5455c8d52cc52603.tar.gz
guru-1be68cda06ad6813184ce84b5455c8d52cc52603.tar.bz2
guru-1be68cda06ad6813184ce84b5455c8d52cc52603.zip
app-misc/gentodo: add 1.1.1
- Remove unused USE flag Signed-off-by: Christopher Fore <csfore@posteo.net>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gentodo/Manifest1
-rw-r--r--app-misc/gentodo/gentodo-1.1.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/gentodo/Manifest b/app-misc/gentodo/Manifest
index 82b2ed8f3..f6b74a7db 100644
--- a/app-misc/gentodo/Manifest
+++ b/app-misc/gentodo/Manifest
@@ -1,2 +1,3 @@
DIST gentodo-0.2.1.tar.gz 20132 BLAKE2B 0cdcbf6ec9ccd6dcb683794838efd4be474f94709197096c5618402c91585eadcf89bfc9e7cd5bdbc1293c49790f63767a43196e6d0da3021ef71c78a3466771 SHA512 000dcd7b22cb316c8f60c6cab9fd4c2af6fb8572a28a1772a802769e2146e26cb28e9d318c54c8aff9d5b0e713fd2ee1fd014c419a76164ab948dff5d1beea29
DIST gentodo-1.1.0.tar.gz 20008 BLAKE2B b79bab8fccea14c27d179c465aa086a6671c83c41341006f9a341052dadc7d8373227e5bbe8596dd3530c84e0124413b12727d9a6b7bacffcccb3df63756b0b5 SHA512 e7d4045d04f32f39d1d5a12515e9f20d27fb2e1188b5150782ee64fb294a040ca193748cb6573e2eb2714f730906920511e00d4a8ed7f63b0018ca1844726c71
+DIST gentodo-1.1.1.tar.gz 19793 BLAKE2B fa07a3003cf899cecfc9b0fdb6b5d783d717e95cfb72f920b10fa4075ea22e7e281eb13e16bfd840da62759d5b7dd7419b0c1ad1f9ed19d1cce5cb439e334aa4 SHA512 707374f47c63be4e42f6e96aeedb2c20b582949dbc6800955d5a287e1e371717379c2806099e82bb7f13c151975af51d451ca1a764da60ba7fe4962a6fff2341
diff --git a/app-misc/gentodo/gentodo-1.1.1.ebuild b/app-misc/gentodo/gentodo-1.1.1.ebuild
new file mode 100644
index 000000000..e66f55aae
--- /dev/null
+++ b/app-misc/gentodo/gentodo-1.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 bash-completion-r1
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/csfore/gentodo.git"
+else
+ SRC_URI="https://github.com/csfore/gentodo/releases/download/${PV}/gentodo-${PV}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Todo program to help enhance your Gentoo workflow"
+HOMEPAGE="https://github.com/csfore/gentodo"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPENDS="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/python-bugzilla
+ dev-python/click
+"
+
+python_install_all() {
+ newbashcomp src/gentodo/gentodo-completions.bash gentodo
+ distutils-r1_python_install_all
+}