aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-06-20 11:43:14 +0100
committerMatt Smith <matt@offtopica.uk>2021-06-20 11:43:28 +0100
commit3a4a28fe33a8bba17620d4e45806fcba433a8b41 (patch)
treefedbe01fb5adaa7d998194e8add0e7799a94b7fd /app-emacs
parentapp-emacs/prop-menu: Init at 0.1.2 (diff)
downloadguru-3a4a28fe33a8bba17620d4e45806fcba433a8b41.tar.gz
guru-3a4a28fe33a8bba17620d4e45806fcba433a8b41.tar.bz2
guru-3a4a28fe33a8bba17620d4e45806fcba433a8b41.zip
app-emacs/idris-mode: Init at 1.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/idris-mode/Manifest1
-rw-r--r--app-emacs/idris-mode/files/50idris-mode-gentoo.el3
-rw-r--r--app-emacs/idris-mode/idris-mode-1.0.ebuild26
-rw-r--r--app-emacs/idris-mode/idris-mode-9999.ebuild26
-rw-r--r--app-emacs/idris-mode/metadata.xml22
5 files changed, 78 insertions, 0 deletions
diff --git a/app-emacs/idris-mode/Manifest b/app-emacs/idris-mode/Manifest
new file mode 100644
index 000000000..09c7bde3a
--- /dev/null
+++ b/app-emacs/idris-mode/Manifest
@@ -0,0 +1 @@
+DIST 1.0.tar.gz 89451 BLAKE2B fc64378dfd113f21b4341143f48ebcf5ae070f312504d9b526f96068e67126b9603826ee8eca3d68629b8fd67ec182d959358efc49fb4cc366ce73b1a6e13ff8 SHA512 f449354ca943fadbee9c07ec1cf109584266d97c5819ab8ead4941d7395c898861b8ba52f0dbeb1986b61294473d55e5f03e8268fc9e998e6228d515bd31fb77
diff --git a/app-emacs/idris-mode/files/50idris-mode-gentoo.el b/app-emacs/idris-mode/files/50idris-mode-gentoo.el
new file mode 100644
index 000000000..31b181918
--- /dev/null
+++ b/app-emacs/idris-mode/files/50idris-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.idr\\'" . idris-mode))
+(autoload 'idris-mode "idris-mode" nil t)
diff --git a/app-emacs/idris-mode/idris-mode-1.0.ebuild b/app-emacs/idris-mode/idris-mode-1.0.ebuild
new file mode 100644
index 000000000..4986726e2
--- /dev/null
+++ b/app-emacs/idris-mode/idris-mode-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/idris-hackers/idris-mode.git"
+else
+ SRC_URI="https://github.com/idris-hackers/idris-mode/archive/refs/tags/${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=""
+fi
+
+DESCRIPTION="Idris syntax highlighting, compiler-supported editing, and interactive REPL"
+HOMEPAGE="https://github.com/idris-hackers/idris-mode"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="app-emacs/prop-menu"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/idris-mode/idris-mode-9999.ebuild b/app-emacs/idris-mode/idris-mode-9999.ebuild
new file mode 100644
index 000000000..4986726e2
--- /dev/null
+++ b/app-emacs/idris-mode/idris-mode-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/idris-hackers/idris-mode.git"
+else
+ SRC_URI="https://github.com/idris-hackers/idris-mode/archive/refs/tags/${PV}.tar.gz"
+ KEYWORDS="~amd64"
+ S=""
+fi
+
+DESCRIPTION="Idris syntax highlighting, compiler-supported editing, and interactive REPL"
+HOMEPAGE="https://github.com/idris-hackers/idris-mode"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="app-emacs/prop-menu"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/idris-mode/metadata.xml b/app-emacs/idris-mode/metadata.xml
new file mode 100644
index 000000000..d99760071
--- /dev/null
+++ b/app-emacs/idris-mode/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>matt@offtopica.uk</email>
+ <name>Matt Smith</name>
+ </maintainer>
+ <longdescription lang="en">
+ This is an emacs mode for editing Idris code.
+
+ This mode was original designed to work with version 1 of the
+ language through an IDE-Protocol. Idris2 uses the next iteration
+ of the same protocol. Idris-mode tries to maintain compatibility
+ with both protocol versions, however, not all the features from
+ the IDE-Protocol have been realised in Idris2. When using
+ idris-mode with Idris2 your experience might be a bit clunky.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">idris-hackers/idris-mode</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>