aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-08-07 19:30:36 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-08-07 19:41:25 +0200
commit6c82bd8f95913720b420a383bd1dc4a2488b9c8c (patch)
treef7795309d35fc745ff152194db160bfc6534c6f9 /app-doc/anarchism
parentapp-misc/navi: Update crates live ebuild (diff)
downloadguru-6c82bd8f95913720b420a383bd1dc4a2488b9c8c.tar.gz
guru-6c82bd8f95913720b420a383bd1dc4a2488b9c8c.tar.bz2
guru-6c82bd8f95913720b420a383bd1dc4a2488b9c8c.zip
app-doc/anarchism: New package.
An anarchist FAQ. Uses the Debian repo as upstream, because the authors release no source files. Bug: https://bugs.gentoo.org/304413 Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-doc/anarchism')
-rw-r--r--app-doc/anarchism/Manifest1
-rw-r--r--app-doc/anarchism/anarchism-15.3.ebuild36
-rw-r--r--app-doc/anarchism/metadata.xml16
3 files changed, 53 insertions, 0 deletions
diff --git a/app-doc/anarchism/Manifest b/app-doc/anarchism/Manifest
new file mode 100644
index 000000000..ad4d8e8cb
--- /dev/null
+++ b/app-doc/anarchism/Manifest
@@ -0,0 +1 @@
+DIST anarchism-15.3.tar.gz 8160295 BLAKE2B 522a2314e6c208a258104412b7620061f952c1a969a11a432cc14bc1a7037d89e0953e82033a9811d461831f9f30c9d0e1924b94e3b8e7deb33e44578ce3f80b SHA512 e0df7ddb8b042eceebf701ec7f8ff9344dc8abefbf2d13f9cf6615c06ff1250f0398ecc281f7c9e77ca49a15f86f04dfdd2f8ad50dc2062223df1c4231736046
diff --git a/app-doc/anarchism/anarchism-15.3.ebuild b/app-doc/anarchism/anarchism-15.3.ebuild
new file mode 100644
index 000000000..cc6c06aa3
--- /dev/null
+++ b/app-doc/anarchism/anarchism-15.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop
+
+DEBIAN_VERSION="${PV}-3"
+
+DESCRIPTION="An anarchist FAQ"
+HOMEPAGE="http://www.anarchistfaq.org/afaq/index.html"
+SRC_URI="https://salsa.debian.org/debian/anarchism/-/archive/debian/${DEBIAN_VERSION}/anarchism-debian-${DEBIAN_VERSION}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-debian-${DEBIAN_VERSION}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ sed -Ei "s|file://(/usr/share/doc/)anarchism|file://${EPREFIX}\1${P}|" \
+ debian/anarchism.desktop || die
+
+ default
+}
+
+src_install() {
+ dodoc -r html markdown README.md
+ domenu debian/anarchism.desktop
+ doicon debian/anarchism.svg
+}
+
+pkg_postinst() {
+ elog "If you wish to symlink the index, the path is /usr/share/doc/anarchism-${PV}/html/index.html"
+ elog "For example:"
+ elog "ln -s /usr/share/doc/anarchism-${PV}/html/index.html ~/Desktop/Anarchist\\ FAQ.html"
+}
diff --git a/app-doc/anarchism/metadata.xml b/app-doc/anarchism/metadata.xml
new file mode 100644
index 000000000..56c89ccd1
--- /dev/null
+++ b/app-doc/anarchism/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@tastytea.de</email>
+ <name>Ronny (tastytea) Gutbrod</name>
+ </maintainer>
+ <longdescription lang="en">
+ The aim of the anarchist FAQ is to present what anarchism really stands
+ for and indicate why you should become an anarchist.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://0xacab.org/ju/afaq/-/issues</bugs-to>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>