aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@riseup.net>2021-04-15 17:21:21 +0200
committerMaciej Barć <xgqt@riseup.net>2021-04-15 17:21:21 +0200
commit0cf1bced1ee29da4c7f0712f535600af46f5cc7b (patch)
tree6f9dcafca6ebc94170c0f357f0203e347bd3ae49 /app-arch
parentdev-vcs/gitahead: add missing deps and QA_FLAGS_IGNORED (diff)
downloadguru-0cf1bced1ee29da4c7f0712f535600af46f5cc7b.tar.gz
guru-0cf1bced1ee29da4c7f0712f535600af46f5cc7b.tar.bz2
guru-0cf1bced1ee29da4c7f0712f535600af46f5cc7b.zip
app-arch/libarchive-qt: bump to 2.0.4
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Maciej Barć <xgqt@riseup.net>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive-qt/Manifest1
-rw-r--r--app-arch/libarchive-qt/libarchive-qt-2.0.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/libarchive-qt/Manifest b/app-arch/libarchive-qt/Manifest
index 7e3812dc5..46d437af4 100644
--- a/app-arch/libarchive-qt/Manifest
+++ b/app-arch/libarchive-qt/Manifest
@@ -1 +1,2 @@
DIST libarchive-qt-2.0.3.tar.gz 52793 BLAKE2B bfc29a21c54421b4c589eb5d444b7d9cb40c9d4f71b3ac36489df5f919e9d6eb2455574b1ad6c435cb3556f5ff697a0e6244554cf2dbaf032c1c77dc454f8328 SHA512 4d3c809a6bac4db576314a6b52893613de3b6d7eefc7ce74271ce5e6c5b73f3650380ba4b987724abda722e70cce3d1555a5ffd470d867ae9e1157cde7e761ee
+DIST libarchive-qt-2.0.4.tar.gz 52779 BLAKE2B a46605eae1880df638933fb780b846b98e6c58407fc601362f5b70823ae0559ae50f72bc85a1addfd6c385d0fa8d2aea07058e03ab6ada5e2425ab23ed78a08a SHA512 37b8719f689f6670543c41ebe1a1e73f4cc1fda48415103708832a94aeee2b27753c6e17e60e6849c05f2a98486e7e819a7d15faf284234bd47c18feb9565893
diff --git a/app-arch/libarchive-qt/libarchive-qt-2.0.4.ebuild b/app-arch/libarchive-qt/libarchive-qt-2.0.4.ebuild
new file mode 100644
index 000000000..74abd09fd
--- /dev/null
+++ b/app-arch/libarchive-qt/libarchive-qt-2.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib xdg cmake
+
+DESCRIPTION="A Qt based archiving solution with libarchive backend"
+HOMEPAGE="https://gitlab.com/marcusbritanicus/libarchive-qt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/marcusbritanicus/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/marcusbritanicus/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="test"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="static-libs"
+
+DEPEND="
+ app-arch/libarchive[lzma,bzip2,zlib]
+ app-arch/lrzip
+ app-arch/lzip
+ app-arch/lzop
+ dev-qt/qtgui:5
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_STATIC=$(usex static-libs)
+ )
+ cmake_src_configure
+}