aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladislav Dudar <seal331gentoo@gmail.com>2024-07-13 08:05:08 +0300
committerVladislav Dudar <seal331gentoo@gmail.com>2024-07-13 08:05:08 +0300
commite3e84ca4261583ab7bc73c101662a757bd6e5520 (patch)
tree6e2d9c295c6a34008c97d2eceb5d07191c6f4cb4
parentx11-terms/dmd5620: add 2.1.0 (diff)
downloadguru-e3e84ca4261583ab7bc73c101662a757bd6e5520.tar.gz
guru-e3e84ca4261583ab7bc73c101662a757bd6e5520.tar.bz2
guru-e3e84ca4261583ab7bc73c101662a757bd6e5520.zip
x11-terms/dmd5620: drop 1.2.0
Signed-off-by: Vladislav Dudar <seal331gentoo@gmail.com>
-rw-r--r--x11-terms/dmd5620/Manifest1
-rw-r--r--x11-terms/dmd5620/dmd5620-1.2.0.ebuild61
-rw-r--r--x11-terms/dmd5620/files/dmd5620-1.2.0-systemlibs-nostrip.patch34
3 files changed, 0 insertions, 96 deletions
diff --git a/x11-terms/dmd5620/Manifest b/x11-terms/dmd5620/Manifest
index 9d26e6ccc9..bee29339b5 100644
--- a/x11-terms/dmd5620/Manifest
+++ b/x11-terms/dmd5620/Manifest
@@ -1,2 +1 @@
-DIST dmd5620-1.2.0.tar.gz 2560536 BLAKE2B e7ccd740cd727c5a21ddef19671e08675eaf66228b4917a56b47923bf3c2c0a23373391db59f83fb30529a616db2df0107732e5106600838a6ba68fb546855a3 SHA512 674c990d08a56458b35cba76d2733ff0b75bed83589f20166ca017af37616072caf11d7b9c8b621945affbc42edfc758bc1e13fa2d0ccf1fbc76a43f6ece9298
DIST dmd5620-2.1.0.tar.gz 14415 BLAKE2B 43b9cd0fe1167ffa365aca7e7503bc78bb4d3d3d279d06ddaad68c4fc3d963b30924a86b684288d970101c0b7254f239ad401b2dc727df097a6ebbaa33d6cf98 SHA512 8d444d2f4579855d9e6cb3f0b5bd63b0735ef8fc1b6dfd41a69283009f097492800697af22d5c81b04f8e488fd12c4bda8e77f6410b5ffab84da2f64acf51444
diff --git a/x11-terms/dmd5620/dmd5620-1.2.0.ebuild b/x11-terms/dmd5620/dmd5620-1.2.0.ebuild
deleted file mode 100644
index 9e38dd07d3..0000000000
--- a/x11-terms/dmd5620/dmd5620-1.2.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs xdg-utils
-
-DESCRIPTION="GTK+ 3.0 implementation of an AT&T / Teletype DMD 5620 emulator."
-HOMEPAGE="https://github.com/sethm/dmd_gtk"
-SRC_URI="https://github.com/sethm/dmd_gtk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/dmd_gtk-${PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="test mirror"
-
-RDEPEND="
- net-libs/libtelnet
- dev-libs/dmd_core
- x11-libs/gtk+:3
- x11-libs/gdk-pixbuf
- x11-libs/cairo
- dev-libs/glib:2
-"
-DEPEND="${RDEPEND}"
-
-BDEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-
-src_prepare() {
- # remove bundled libraries
- rm "${S}"/src/libtelnet.c "${S}"/src/libtelnet.h "${S}"/lib/libdmd_core.a || die "failed to remove bundled libraries"
- rmdir "${S}"/lib
- # apply patches
- eapply "${FILESDIR}/${PN}-1.2.0-systemlibs-nostrip.patch"
- eapply_user
- # use system pkgconfig
- sed -i -e "s:pkgconfig:$(tc-getPKG_CONFIG):" "${S}"/Makefile || die "sed failed"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" LD="$(tc-getLD)"
-}
-
-src_install() {
- emake PREFIX=/usr DESTDIR="${D}" install
- dodoc "${S}/LICENSE.md"
- dodoc "${S}/README.md"
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
-}
diff --git a/x11-terms/dmd5620/files/dmd5620-1.2.0-systemlibs-nostrip.patch b/x11-terms/dmd5620/files/dmd5620-1.2.0-systemlibs-nostrip.patch
deleted file mode 100644
index d24ae17054..0000000000
--- a/x11-terms/dmd5620/files/dmd5620-1.2.0-systemlibs-nostrip.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Index: dmd_gtk-1.2.0/Makefile
-===================================================================
---- dmd_gtk-1.2.0.orig/Makefile
-+++ dmd_gtk-1.2.0/Makefile
-@@ -1,13 +1,16 @@
- SRCDIR = src
- LIBDIR = lib
- CC = gcc
--CFLAGS = $(shell pkg-config --cflags gtk+-3.0) -Wall -std=gnu99
-+CFLAGS = $(shell printenv CFLAGS)
-+CFLAGS += $(shell pkg-config --cflags gtk+-3.0) $(shell pkg-config --cflags libtelnet) -Wall -std=gnu99
- GTKLIBS = $(shell pkg-config --libs gtk+-3.0)
-+TELNETLIBS = $(shell pkg-config --libs libtelnet)
- EXE = dmd5620
--CSRC = $(wildcard src/*.c)
-+CSRC = src/dmd_5620.c
- OBJ = $(CSRC:.c=.o)
--LDFLAGS = $(GTKLIBS) -lm -lpthread -lc -ldl
--CORELIB = $(LIBDIR)/libdmd_core.a
-+LDFLAGS = $(shell printenv LDFLAGS)
-+LDFLAGS += $(GTKLIBS) $(TELNETLIBS) -lm -lpthread -lc -ldl
-+CORELIB = $(shell pkg-config --libs dmd_core)
-
- ifeq ($(PREFIX),)
- PREFIX := /usr/local
-@@ -16,7 +19,7 @@ endif
- ifdef DEBUG
- CFLAGS+ = -g -O0
- else
--CFLAGS += -O3 -Os -s
-+CFLAGS += -O3 -Os
- endif
-
- .PHONY: all clean