aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Zapparov <alexey@zapparov.com>2022-01-02 16:45:32 +0100
committerAlexey Zapparov <alexey@zapparov.com>2022-01-02 16:45:32 +0100
commit35a714d90af04df573786ce35f5501ee5e7c11ba (patch)
treee51513fd312c1ff7cd50cdc8279b1c227d7d1e66
parentdev-python/yaql: drop test dep dev-python/hacking (diff)
downloadguru-35a714d90af04df573786ce35f5501ee5e7c11ba.tar.gz
guru-35a714d90af04df573786ce35f5501ee5e7c11ba.tar.bz2
guru-35a714d90af04df573786ce35f5501ee5e7c11ba.zip
dev-ruby/ruby-install: fix 0.8.3-r2
Fix Makefile's version to include Gentoo ebuild revision. Closes: https://bugs.gentoo.org/830341 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alexey Zapparov <alexey@zapparov.com>
-rw-r--r--dev-ruby/ruby-install/ruby-install-0.8.3-r2.ebuild (renamed from dev-ruby/ruby-install/ruby-install-0.8.3-r1.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-ruby/ruby-install/ruby-install-0.8.3-r1.ebuild b/dev-ruby/ruby-install/ruby-install-0.8.3-r2.ebuild
index 1c97407cc..46ccb1fad 100644
--- a/dev-ruby/ruby-install/ruby-install-0.8.3-r1.ebuild
+++ b/dev-ruby/ruby-install/ruby-install-0.8.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -31,6 +31,13 @@ src_test() {
emake test
}
+src_prepare() {
+ default
+
+ sed -i Makefile -e "s/^VERSION=.\+$/VERSION=${PVR}/" \
+ || die "Cannot fix doc location to follow Gentoo/FHS guidelines"
+}
+
src_install() {
emake DESTDIR="${D}" PREFIX="/usr" install
}