aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeather <Heather@cynede.net>2013-05-26 11:01:38 +0400
committerHeather <Heather@cynede.net>2013-09-23 16:41:00 +0400
commit2faedf0900367fa8803fd340923e36eb146fcd45 (patch)
tree0135eda82164b6b597a01f10551a08cfafc1d29e /dev-util/mono-tools
parentDoesn't require previous mono to be installed (diff)
downloaddotnet-2faedf0900367fa8803fd340923e36eb146fcd45.tar.gz
dotnet-2faedf0900367fa8803fd340923e36eb146fcd45.tar.bz2
dotnet-2faedf0900367fa8803fd340923e36eb146fcd45.zip
3.0.7 goes upstream \o/
rm mono-3.0.10 doesn't require previous mono for 9999 pacakge repair 3.0.7 ebuild as stable, rewrite 3.0.11 / 9999 ebuilds with mono-env eclass and w/o go-mono only tests is failing stable -> unstable -> live exclude go-mono eclass from libgdiplus force you to update exclude go-mono eclass from xsp ebuilds correct mono-debugger ebuild / exclude go-mono eclass exclude go-mono eclass from mono-tools remove md 4.0 ebuild vanish go-mono eclasses lesser qa don't restrict test
Diffstat (limited to 'dev-util/mono-tools')
-rw-r--r--dev-util/mono-tools/mono-tools-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-util/mono-tools/mono-tools-9999.ebuild b/dev-util/mono-tools/mono-tools-9999.ebuild
index 5f46ccd..7f6c6ed 100644
--- a/dev-util/mono-tools/mono-tools-9999.ebuild
+++ b/dev-util/mono-tools/mono-tools-9999.ebuild
@@ -2,31 +2,30 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/mono-tools/mono-tools-9999.ebuild $
-EAPI="4"
+EAPI=5
-inherit go-mono mono autotools
+inherit base mono autotools git-2
DESCRIPTION="Set of useful Mono related utilities"
HOMEPAGE="http://www.mono-project.com/"
+EGIT_REPO_URI="git://github.com/mono/${PN}.git"
+
LICENSE="GPL-2 MIT"
SLOT="0"
KEYWORDS=""
IUSE="+webkit gtkhtml"
-RDEPEND="=virtual/monodoc-${GO_MONO_REL_PV}*
+RDEPEND="virtual/monodoc
>=dev-dotnet/gtk-sharp-2.12.6:2
>=dev-dotnet/glade-sharp-2.12.6:2
>=dev-dotnet/gconf-sharp-2:2
gtkhtml? ( >=dev-dotnet/gtkhtml-sharp-2.24.0:2 )
webkit? ( >=dev-dotnet/webkit-sharp-0.2-r1 )"
-
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig"
-
PATCHES=( "${FILESDIR}/${PN}-2.8-html-renderer-fixes.patch" )
-
MAKEOPTS="${MAKEOPTS} -j1" #nowarn
pkg_setup() {
if ! use webkit && ! use gtkhtml
@@ -36,7 +35,7 @@ pkg_setup() {
}
src_prepare() {
- go-mono_src_prepare
+ base_src_prepare
# Stop getting ACLOCAL_FLAGS command not found problem like bug #298813
sed -i -e '/ACLOCAL_FLAGS/d' Makefile.am || die
@@ -49,5 +48,5 @@ src_configure() {
--disable-gecko \
$(use_enable gtkhtml) \
$(use_enable webkit) \
- --disable-monowebbrowser
+ --disable-monowebbrowser || die
}