aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2017-06-30 17:30:20 +0400
committerMikhail Pukhlikov <cynede@gentoo.org>2017-06-30 17:30:20 +0400
commitbaed38b753d3f3d8ef66fd19a17a41ed5c161616 (patch)
tree98c56266abac9a7fc960983a3a895c06e6ac464c /dev-lang
parentMerge pull request #307 from ArsenShnurkov/mypad-dependency (diff)
downloaddotnet-baed38b753d3f3d8ef66fd19a17a41ed5c161616.tar.gz
dotnet-baed38b753d3f3d8ef66fd19a17a41ed5c161616.tar.bz2
dotnet-baed38b753d3f3d8ef66fd19a17a41ed5c161616.zip
add experimental mono-5.2.0.196
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/mono-5.2.0.196.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 86a24f7..484e2d1 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -1 +1,2 @@
DIST mono-5.0.1.1.tar.bz2 154477308 SHA256 48d6ae71d593cd01bf0f499de569359d45856cda325575e1bacb5fabaa7e9718 SHA512 de2a8a3580b8236bafdc7e6967d68da08bf2dc775bce5166aba6134c1b986ae7fc56b97743d5122de14bf8fe074d3508c07324735616439dea0913633ee817da WHIRLPOOL 21fa5f28ed85873d41b1d3a724e7a47c678a177a350a648bf148b6aa870f68caaf47da9ba139a0c3d4a71cc15416a086642a522676a542771e5142c757c9fea6
+DIST mono-5.2.0.196.tar.bz2 158175736 SHA256 731634b24c89680660fed1efd63a39ec6c052e519ae9a2dce61f875598329366 SHA512 9a767d3fa30ef2d96cce13767c5da5604443495071da475a1f1452916501f2b6a94c2a45dfeee49cc0423cfeee48640a28989ea5d61270fbd51cadd143dc425c WHIRLPOOL 85841722c311d5eb976213a18a771930bd67994706007f1ffa536c4380c877f2b7d422798f51a6567554eb93e81fff33477106bba534881fcd985076f8168fa6
diff --git a/dev-lang/mono/mono-5.2.0.196.ebuild b/dev-lang/mono/mono-5.2.0.196.ebuild
new file mode 100644
index 0000000..2640c83
--- /dev/null
+++ b/dev-lang/mono/mono-5.2.0.196.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ dev-util/cmake
+ !dev-lang/mono-basic
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1.1-x86_32.patch
+)
+
+#S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ if use kernel_linux; then
+ if linux_config_exists; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See http://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ #TODO: resolve problem with newer binutils
+ #bug: https://bugs.gentoo.org/show_bug.cgi?id=600664
+ #append-flags -fPIC
+
+ default
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+multilib_src_install() {
+ default_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}