aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikhail Pukhlikov <cynede@gentoo.org>2016-07-15 14:43:28 +0400
committerMikhail Pukhlikov <cynede@gentoo.org>2016-07-15 14:43:28 +0400
commit3ba458a5466f25949371d665a455fcf83fa1b8fc (patch)
tree9f463e91fd67a03d5ee8dd4fd25971e738563d0c /dev-lang
parentMerge pull request #199 from bsagal/master (diff)
downloaddotnet-3ba458a5466f25949371d665a455fcf83fa1b8fc.tar.gz
dotnet-3ba458a5466f25949371d665a455fcf83fa1b8fc.tar.bz2
dotnet-3ba458a5466f25949371d665a455fcf83fa1b8fc.zip
drop nemerle support
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nemerle/Manifest2
-rw-r--r--dev-lang/nemerle/metadata.xml15
-rw-r--r--dev-lang/nemerle/nemerle-1.1b-r1.ebuild92
-rw-r--r--dev-lang/nemerle/nemerle-1.2-r1.ebuild92
-rw-r--r--dev-lang/nemerle/nemerle-9999.ebuild102
5 files changed, 0 insertions, 303 deletions
diff --git a/dev-lang/nemerle/Manifest b/dev-lang/nemerle/Manifest
deleted file mode 100644
index 2ef2d2f..0000000
--- a/dev-lang/nemerle/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST v1.1b.tar.gz 11495251 SHA256 7e84a6927648afb57f3a14ca6bc9f75e082f8ccb0d6593d90400c6cc7f87bfb2 SHA512 61962c7b6ad14afd2957733f5aa4dcde3493c9d892673a6c18e6e568d01c1298bf268c8c964df5f14363bdfb5438c22a7a7de0458baf794a38c2b758b7efa13d WHIRLPOOL 75ee6e859fde984983beea2bd1920855ff6c8fb14e83805396fe9610af4a536ddce3b8b609281e48cf7a8c062b7cd170acfcd8d4221540ba40e9f0af15ed4dd2
-DIST v1.2.tar.gz 16734095 SHA256 47afeb3cb3d42db917aff21082cd9460b1d25a9e62cb90e502fa5438a9075fb5 SHA512 ecfea56a846381c386b0099ae3bdcbab9a369d5db1aff856afe56d4fb678e0af7d45e3cfc1ff644391ecc56d170de06a9805b8bfd00a050e666ca5feb2dc4599 WHIRLPOOL 97960348c7967dcb0f759143d135db9e305f3766afaf858eed4c4f0d79ad123347ee40ba3477c9d80d7f1d5e443a04a39c0ac946fa672eefbda548a82cce1b90
diff --git a/dev-lang/nemerle/metadata.xml b/dev-lang/nemerle/metadata.xml
deleted file mode 100644
index 27bfd14..0000000
--- a/dev-lang/nemerle/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>dotnet@gentoo.org</email>
- <description>Gentoo Dotnet Project</description>
- </maintainer>
- <longdescription>
- Mono/.NET programming language with macros support
- </longdescription>
- <use>
- <flag name='binary'>Using binary bootstrap</flag>
- <flag name='indent'>Eperimental branch with indent by default</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-lang/nemerle/nemerle-1.1b-r1.ebuild b/dev-lang/nemerle/nemerle-1.1b-r1.ebuild
deleted file mode 100644
index 06e48b4..0000000
--- a/dev-lang/nemerle/nemerle-1.1b-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-USE_DOTNET="net35 net40 net45"
-
-inherit dotnet multilib eutils
-
-DESCRIPTION="A hybrid programming language for .NET / Mono platforms"
-HOMEPAGE="http://www.nemerle.org/"
-
-SRC_URI="https://github.com/rsdn/nemerle/archive/v${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+binary"
-
-MAKEOPTS="${MAKEOPTS} -j1" #nowarn
-DEPEND=">dev-lang/mono-2.11.3"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]] && has collision-protect ${FEATURES}; then
- if [ -f /usr/bin/ncc]; then
- eerror "FEATURES=\"collision-protect\" is enabled, which will prevent overwriting"
- eerror "symlinks that were formerly managed by eselect opengl. You must disable"
- eerror "collision-protect or remove /usr/bin/ncc"
- die "collision-protect cannot overwrite libGLU$(get_libname)*"
- fi
- fi
-}
-
-src_configure() { :; }
-src_compile() {
- if ! use binary; then
- elog "Nemerle sources compiling : "
- exbuild NemerleAll-Mono.nproj /t:Stage1
- fi # ! use binary
-}
-
-src_install()
-{
- elog "Installing libraries"
- if ! use binary; then
- insinto "/usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}"
- doins bin/Release/mono-"${FRAMEWORK}"/Stage1/*.dll || die "installing libraries failed"
- elog "Registering libraries to egac"
- local nemerledll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.dll
- egacinstall "${nemerledll}" \
- || die "couldn't install ${nemerledll} in the global assembly cache"
- local nemerlecompilerdll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.Compiler.dll
- egacinstall "${nemerlecompilerdll}" \
- || die "couldn't install ${nemerlecompilerdll} in the global assembly cache"
- local nemerlemacrosdll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.Macros.dll
- egacinstall "${nemerlemacrosdll}" \
- || die "couldn't install ${nemerlemacrosdll} in the global assembly cache"
- elog "Installing ncc"
- dodoc README AUTHORS INSTALL NEWS
- into /usr
- doins bin/Release/mono-"${FRAMEWORK}"/Stage1/ncc.exe
- else # binary
- case ${FRAMEWORK} in
- "3.5") Bootstrap="boot";;
- "4.0") Bootstrap="boot-4.0";;
- "4.5")
- ewarn "there is no 4.5 binaries, using 4.0"
- FRAMEWORK="4.0"
- Bootstrap="boot-4.0"
- ;;
- esac
- insinto "/usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}"
- doins ${Bootstrap}/*.dll || die "installing libraries failed"
- elog "Registering libraries to egac"
- local nemerledll=${Bootstrap}/Nemerle.dll
- egacinstall "${nemerledll}" \
- || die "couldn't install ${nemerledll} in the global assembly cache"
- local nemerlecompilerdll=${Bootstrap}/Nemerle.Compiler.dll
- egacinstall "${nemerlecompilerdll}" \
- || die "couldn't install ${nemerlecompilerdll} in the global assembly cache"
- local nemerlemacrosdll=${Bootstrap}/Nemerle.Macros.dll
- egacinstall "${nemerlemacrosdll}" \
- || die "couldn't install ${nemerlemacrosdll} in the global assembly cache"
- elog "Installing ncc"
- dodoc README AUTHORS INSTALL NEWS
- into /usr
- doins ${Bootstrap}/ncc.exe
- fi
- make_wrapper ncc "mono /usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}/ncc.exe"
-}
diff --git a/dev-lang/nemerle/nemerle-1.2-r1.ebuild b/dev-lang/nemerle/nemerle-1.2-r1.ebuild
deleted file mode 100644
index 06e48b4..0000000
--- a/dev-lang/nemerle/nemerle-1.2-r1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-USE_DOTNET="net35 net40 net45"
-
-inherit dotnet multilib eutils
-
-DESCRIPTION="A hybrid programming language for .NET / Mono platforms"
-HOMEPAGE="http://www.nemerle.org/"
-
-SRC_URI="https://github.com/rsdn/nemerle/archive/v${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+binary"
-
-MAKEOPTS="${MAKEOPTS} -j1" #nowarn
-DEPEND=">dev-lang/mono-2.11.3"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]] && has collision-protect ${FEATURES}; then
- if [ -f /usr/bin/ncc]; then
- eerror "FEATURES=\"collision-protect\" is enabled, which will prevent overwriting"
- eerror "symlinks that were formerly managed by eselect opengl. You must disable"
- eerror "collision-protect or remove /usr/bin/ncc"
- die "collision-protect cannot overwrite libGLU$(get_libname)*"
- fi
- fi
-}
-
-src_configure() { :; }
-src_compile() {
- if ! use binary; then
- elog "Nemerle sources compiling : "
- exbuild NemerleAll-Mono.nproj /t:Stage1
- fi # ! use binary
-}
-
-src_install()
-{
- elog "Installing libraries"
- if ! use binary; then
- insinto "/usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}"
- doins bin/Release/mono-"${FRAMEWORK}"/Stage1/*.dll || die "installing libraries failed"
- elog "Registering libraries to egac"
- local nemerledll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.dll
- egacinstall "${nemerledll}" \
- || die "couldn't install ${nemerledll} in the global assembly cache"
- local nemerlecompilerdll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.Compiler.dll
- egacinstall "${nemerlecompilerdll}" \
- || die "couldn't install ${nemerlecompilerdll} in the global assembly cache"
- local nemerlemacrosdll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.Macros.dll
- egacinstall "${nemerlemacrosdll}" \
- || die "couldn't install ${nemerlemacrosdll} in the global assembly cache"
- elog "Installing ncc"
- dodoc README AUTHORS INSTALL NEWS
- into /usr
- doins bin/Release/mono-"${FRAMEWORK}"/Stage1/ncc.exe
- else # binary
- case ${FRAMEWORK} in
- "3.5") Bootstrap="boot";;
- "4.0") Bootstrap="boot-4.0";;
- "4.5")
- ewarn "there is no 4.5 binaries, using 4.0"
- FRAMEWORK="4.0"
- Bootstrap="boot-4.0"
- ;;
- esac
- insinto "/usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}"
- doins ${Bootstrap}/*.dll || die "installing libraries failed"
- elog "Registering libraries to egac"
- local nemerledll=${Bootstrap}/Nemerle.dll
- egacinstall "${nemerledll}" \
- || die "couldn't install ${nemerledll} in the global assembly cache"
- local nemerlecompilerdll=${Bootstrap}/Nemerle.Compiler.dll
- egacinstall "${nemerlecompilerdll}" \
- || die "couldn't install ${nemerlecompilerdll} in the global assembly cache"
- local nemerlemacrosdll=${Bootstrap}/Nemerle.Macros.dll
- egacinstall "${nemerlemacrosdll}" \
- || die "couldn't install ${nemerlemacrosdll} in the global assembly cache"
- elog "Installing ncc"
- dodoc README AUTHORS INSTALL NEWS
- into /usr
- doins ${Bootstrap}/ncc.exe
- fi
- make_wrapper ncc "mono /usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}/ncc.exe"
-}
diff --git a/dev-lang/nemerle/nemerle-9999.ebuild b/dev-lang/nemerle/nemerle-9999.ebuild
deleted file mode 100644
index 6949ae4..0000000
--- a/dev-lang/nemerle/nemerle-9999.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-USE_DOTNET="net35 net40 net45"
-
-inherit dotnet git-2 multilib eutils
-
-DESCRIPTION="A hybrid programming language for .NET / Mono platforms"
-HOMEPAGE="http://www.nemerle.org/"
-
-SRC_URI=""
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="+binary -indent"
-
-if use indent; then
- ewarn "indent is very experimental branch"
- ewarn "usual Nemerle code will definetly fail."
- EGIT_REPO_URI="git://github.com/Heather/Nemerle.git"
- EGIT_MASTER="indent"
-else
- EGIT_REPO_URI="git://github.com/rsdn/nemerle.git"
- EGIT_MASTER="master"
-fi
-
-MAKEOPTS="${MAKEOPTS} -j1" #nowarn
-DEPEND=">dev-lang/mono-2.11.3"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]] && has collision-protect ${FEATURES}; then
- if [ -f /usr/bin/ncc]; then
- eerror "FEATURES=\"collision-protect\" is enabled, which will prevent overwriting"
- eerror "symlinks that were formerly managed by eselect opengl. You must disable"
- eerror "collision-protect or remove /usr/bin/ncc"
- die "collision-protect cannot overwrite libGLU$(get_libname)*"
- fi
- fi
-}
-
-src_configure() { :; }
-src_compile() {
- if ! use binary; then
- elog "Nemerle sources compiling : "
- exbuild NemerleAll-Mono.nproj /t:Stage1
- fi # ! use binary
-}
-
-src_install()
-{
- elog "Installing libraries"
- if ! use binary; then
- insinto "/usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}"
- doins bin/Release/mono-"${FRAMEWORK}"/Stage1/*.dll || die "installing libraries failed"
- elog "Registering libraries to egac"
- local nemerledll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.dll
- egacinstall "${nemerledll}" \
- || die "couldn't install ${nemerledll} in the global assembly cache"
- local nemerlecompilerdll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.Compiler.dll
- egacinstall "${nemerlecompilerdll}" \
- || die "couldn't install ${nemerlecompilerdll} in the global assembly cache"
- local nemerlemacrosdll=bin/Release/mono-"${FRAMEWORK}"/Stage1/Nemerle.Macros.dll
- egacinstall "${nemerlemacrosdll}" \
- || die "couldn't install ${nemerlemacrosdll} in the global assembly cache"
- elog "Installing ncc"
- dodoc README AUTHORS INSTALL NEWS
- into /usr
- doins bin/Release/mono-"${FRAMEWORK}"/Stage1/ncc.exe
- else # binary
- case ${FRAMEWORK} in
- "3.5") Bootstrap="boot";;
- "4.0") Bootstrap="boot-4.0";;
- "4.5")
- ewarn "there is no 4.5 binaries, using 4.0"
- FRAMEWORK="4.0"
- Bootstrap="boot-4.0"
- ;;
- esac
- insinto "/usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}"
- doins ${Bootstrap}/*.dll || die "installing libraries failed"
- elog "Registering libraries to egac"
- local nemerledll=${Bootstrap}/Nemerle.dll
- egacinstall "${nemerledll}" \
- || die "couldn't install ${nemerledll} in the global assembly cache"
- local nemerlecompilerdll=${Bootstrap}/Nemerle.Compiler.dll
- egacinstall "${nemerlecompilerdll}" \
- || die "couldn't install ${nemerlecompilerdll} in the global assembly cache"
- local nemerlemacrosdll=${Bootstrap}/Nemerle.Macros.dll
- egacinstall "${nemerlemacrosdll}" \
- || die "couldn't install ${nemerlemacrosdll} in the global assembly cache"
- elog "Installing ncc"
- dodoc README AUTHORS INSTALL NEWS
- into /usr
- doins ${Bootstrap}/ncc.exe
- fi
- make_wrapper ncc "mono /usr/$(get_libdir)/mono/${PN}/${FRAMEWORK}/ncc.exe"
-}