aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgrbd <garlicbready@googlemail.com>2018-03-25 19:47:26 +0100
committergrbd <garlicbready@googlemail.com>2018-03-25 19:47:26 +0100
commit2ea538a5d9d5e84f6fbefae49785ddb196768c37 (patch)
treed6ccbf6869ffdab362b1fbc11f7231d0cdd054ff /dev-lang
parentfix #384 (diff)
downloaddotnet-2ea538a5d9d5e84f6fbefae49785ddb196768c37.tar.gz
dotnet-2ea538a5d9d5e84f6fbefae49785ddb196768c37.tar.bz2
dotnet-2ea538a5d9d5e84f6fbefae49785ddb196768c37.zip
Added latest mono releases
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/Manifest2
-rw-r--r--dev-lang/mono/mono-5.10.0.160.ebuild110
-rw-r--r--dev-lang/mono/mono-5.10.0.179.ebuild110
3 files changed, 222 insertions, 0 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 00c5414..27ca072 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -1,4 +1,6 @@
DIST mono-5.0.1.1.tar.bz2 154477308 SHA256 48d6ae71d593cd01bf0f499de569359d45856cda325575e1bacb5fabaa7e9718 SHA512 de2a8a3580b8236bafdc7e6967d68da08bf2dc775bce5166aba6134c1b986ae7fc56b97743d5122de14bf8fe074d3508c07324735616439dea0913633ee817da WHIRLPOOL 21fa5f28ed85873d41b1d3a724e7a47c678a177a350a648bf148b6aa870f68caaf47da9ba139a0c3d4a71cc15416a086642a522676a542771e5142c757c9fea6
+DIST mono-5.10.0.160.tar.bz2 210503187 SHA256 167d3e1504bfb4fdbf08708f75937bf0e8421bf481de1723d9fa219dc7c8f8d8 SHA512 60e9781309a8b92626ba31bb3b9c98faa63c92b494f20399c8fce50b4370c774c361fca3150d30ea7c672fba17ecc0c2c057682043cca7172857b286f25d115f WHIRLPOOL 6ae83ee98471425bb543a7811888422b0d9b2995772ab1c3fa41c53a370b071c77d5fbdced4f1504b4c63f2a69829e439021c15f07981866b6c648f24a10328b
+DIST mono-5.10.0.179.tar.bz2 210710890 SHA256 e7bdd638d456364abc34440523cef39f4f89e6ee4e7b0a329d3e42fc74de5cd8 SHA512 bda3e13f8c1598ecf2ab4ad288a4f92b24e91262c2e4ddf318d2dba981198fd28427a4ff455e68f71c88b995db950b85da69d197ce04147281ffa94a994e3434 WHIRLPOOL 21b4c531a9145793fb5522526412a6d93012bfdb457f8f556e69df52baf30479daf7c7e5431cd9c15ba111e78d7e30720c0803bf54b53164b50e66592cce22f1
DIST mono-5.11.0.132.tar.bz2 208457253 SHA256 e04847b69ebf5cc34779fd3cd50cf5a67befaa33a49deb209dcc8700e1b3ec1f SHA512 56058e5ad62a31b6e8748de94d1f416f18f3a85fd996b9c4560fc552b96e00cd3b326b8e98e3736eccc131f19e3525a5982fa4781d5d165d4d4f4f0f64cda689 WHIRLPOOL be0977ea7a60257aba7a9eca3fa1a8793b7f693ffa9c54354207b0d0966841f65e82a459dab5d4bf260d331783a96f50babd40d3d6df76748970a46e58db1981
DIST mono-5.2.0.196.tar.bz2 158175736 SHA256 731634b24c89680660fed1efd63a39ec6c052e519ae9a2dce61f875598329366 SHA512 9a767d3fa30ef2d96cce13767c5da5604443495071da475a1f1452916501f2b6a94c2a45dfeee49cc0423cfeee48640a28989ea5d61270fbd51cadd143dc425c WHIRLPOOL 85841722c311d5eb976213a18a771930bd67994706007f1ffa536c4380c877f2b7d422798f51a6567554eb93e81fff33477106bba534881fcd985076f8168fa6
DIST mono-5.2.0.224.tar.bz2 158434164 SHA256 03b8e463032bc425673dec844b35b4c669f5b99b0e45521195efb3741a9f5e94 SHA512 914ab11c892f6e59c1a89d92eb4b130a62ea606691820f9d9f48a2a68f7de3e593c233be071cd37ad5d817c5f5fda6892f89f1b0985fc44de97c1297300c706b WHIRLPOOL 3c16019246341dc1abcc98358bc977142ff35510c226a76d5069bce0cece4754c1f81ca176f1ad988aabebfd482a03b524267aa3136e0df144c703ba3bea6c6f
diff --git a/dev-lang/mono/mono-5.10.0.160.ebuild b/dev-lang/mono/mono-5.10.0.160.ebuild
new file mode 100644
index 0000000..f25dd8d
--- /dev/null
+++ b/dev-lang/mono/mono-5.10.0.160.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~arm64"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ dev-util/cmake
+ !dev-lang/mono-basic
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1.1-x86_32.patch
+)
+
+#S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ if use kernel_linux; then
+ if linux_config_exists; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See https://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ #TODO: resolve problem with newer binutils
+ #bug: https://bugs.gentoo.org/show_bug.cgi?id=600664
+ #append-flags -fPIC
+
+ default
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+multilib_src_install() {
+ default_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}
diff --git a/dev-lang/mono/mono-5.10.0.179.ebuild b/dev-lang/mono/mono-5.10.0.179.ebuild
new file mode 100644
index 0000000..f25dd8d
--- /dev/null
+++ b/dev-lang/mono/mono-5.10.0.179.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils linux-info mono-env flag-o-matic pax-utils versionator multilib-minimal
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.mono-project.com/Main_Page"
+SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~arm64"
+
+IUSE="nls minimal pax_kernel xen doc"
+
+COMMONDEPEND="
+ !minimal? ( >=dev-dotnet/libgdiplus-2.10 )
+ ia64? ( sys-libs/libunwind )
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMONDEPEND}
+ || ( www-client/links www-client/lynx )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/bc
+ virtual/yacc
+ pax_kernel? ( sys-apps/elfix )
+ dev-util/cmake
+ !dev-lang/mono-basic
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.1.1-x86_32.patch
+)
+
+#S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ if use kernel_linux; then
+ if linux_config_exists; then
+ linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
+ else
+ # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
+ ewarn "kernel config not found"
+ ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
+ ewarn "See https://bugs.gentoo.org/261869 for more info."
+ fi
+ fi
+}
+
+pkg_setup() {
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
+ # get killed in the build proces when MPROTECT is enable. #286280
+ # RANDMMAP kill the build proces to #347365
+ # use paxmark.sh to get PT/XT logic #532244
+ if use pax_kernel ; then
+ ewarn "We are disabling MPROTECT on the mono binary."
+
+ # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
+ sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
+ fi
+
+ # mono build system can fail otherwise
+ strip-flags
+
+ #TODO: resolve problem with newer binutils
+ #bug: https://bugs.gentoo.org/show_bug.cgi?id=600664
+ #append-flags -fPIC
+
+ default
+ # PATCHES contains configure.ac patch
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_with xen xen_opt)
+ --without-ikvm-native
+ --disable-dtrace
+ $(use_with doc mcs-docs)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+multilib_src_test() {
+ cd mcs/tests || die
+ emake check
+}
+
+multilib_src_install() {
+ default_src_install
+
+ # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
+ # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
+ # for reference.
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
+ rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
+}