aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-armada/xf86-video-armada-0.0.2.ebuild')
-rw-r--r--x11-drivers/xf86-video-armada/xf86-video-armada-0.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-armada/xf86-video-armada-0.0.2.ebuild b/x11-drivers/xf86-video-armada/xf86-video-armada-0.0.2.ebuild
new file mode 100644
index 0000000..1861929
--- /dev/null
+++ b/x11-drivers/xf86-video-armada/xf86-video-armada-0.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+AUTOTOOLS_AUTORECONF="1"
+XORG_BASE_INDIVIDUAL_URI=""
+XORG_DRI="always"
+
+inherit autotools-utils xorg-2
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/VCTLabs/xf86-video-armada"
+ EGIT_BRANCH="devel"
+ KEYWORDS=""
+ inherit git-r3
+else
+ SRC_URI="mirror://gentoo/${P}.tar.gz"
+ KEYWORDS="~arm"
+fi
+
+DESCRIPTION="Xorg graphics driver for KMS based systems with pluggable GPU backend"
+
+RDEPEND=">=x11-base/xorg-server-1.18"
+
+DEPEND="${RDEPEND}
+ x11-libs/libetnaviv
+ x11-libs/libdrm-armada
+"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ # note: vivante requires libGAL
+ XORG_CONFIGURE_OPTIONS=(
+ --disable-vivante
+ --enable-etnaviv
+ )
+}