aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-10-10 22:39:30 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-10-10 22:39:30 -0700
commitf9bd18168580633d37b0bee8af3bcb3fbd956196 (patch)
tree9cf04f87f33194604954e83f9d75d8cbf03ae27d /net-libs/webkit-gtk
parentupdated xorg server git and added latest release version (diff)
downloadarm-f9bd18168580633d37b0bee8af3bcb3fbd956196.tar.gz
arm-f9bd18168580633d37b0bee8af3bcb3fbd956196.tar.bz2
arm-f9bd18168580633d37b0bee8af3bcb3fbd956196.zip
updated webkit-gtk to latest version
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/Manifest1
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch22
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild285
3 files changed, 308 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index 72e1452..7e303d6 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -3,3 +3,4 @@ DIST webkitgtk-2.4.7.tar.xz 9826208 SHA256 f5cf26e39abf1d6b2d25f1398348fef6bbe6c
DIST webkitgtk-2.4.8.tar.xz 9827632 SHA256 68f11559cb178679ca92acc9e3a3d7febede7acb7b98afd7fb761875bbc6bd23 SHA512 31b8b87142730aa27e5bd4fe85b0de2116fd492ef469592512c185d60df428a9913d6c2738ce57439bf9db10864ed9c121ddbc2a4da2f715818a70885c81c0de WHIRLPOOL 851e3973c00096dd3a98e64bfa9f9f0f278c3513656af9a9aa72442cd6c594119adefafa6c06d05e431ec77bf6e9f1e10432e9b6895d777adfe2952843602ef2
DIST webkitgtk-2.4.9.tar.xz 9840740 SHA256 afdf29e7828816cad0be2604cf19421e96d96bf493987328ffc8813bb20ac564 SHA512 5dfe5c31e0fcbab5e468a18e08918a439b214dcd620386fa32d35e9110e479b552a4b0b88a1bb8574b34445d5cc5219be349feded32fc1d2791a6c6279d61f98 WHIRLPOOL 26141cd12878bc8136ecffc1636fdcb037f342e5c27c8c557117564af9d1673af84c8c4fd10d3fdbe890bdf183791b18a210f57de9750422959a45c60390076c
DIST webkitgtk-2.8.4.tar.xz 10446180 SHA256 30bd366bd970d4bac2f9ef5bff0fb935376bf91ea2aaa2a5183fe5fdbec20fbd SHA512 5395e0b546447dcbcf4da683fa32b70e154176568d35fc3ba720ee1ff0d64aad8b5db05b778436796809ab16e29c2a26639e0c55cbf8176443c0181d0ac10977 WHIRLPOOL c91d3230ba539739d65135bf5d2260fc7f5f01a2544db35dfd4b9049ff0d158cdf3b87743f2464caa2fd8a0cb57f583cae5ba6264e2aa8025019794645cb251f
+DIST webkitgtk-2.8.5.tar.xz 10455256 SHA256 3d1f0c534935f43fd74df90f2648fcee672d60f1f57a30fa557a77891ae04d20 SHA512 b87a4149aa133824c7855d562a872fef9067d8c7a78026b9ec29d9eb0798a4da827aac4a1ec4eb1a117f7ae50b14c415c6f04ba4ddee851cf55e2dc503c3eddb WHIRLPOOL 1bb1c542d73db31985d4afc6a9ab59730118e57f99aba1a8e81820880bf832386f77aee70f4a50cece180fdb905b7aa5a0f08b91a5eb64a77c3ad5dd82792ead
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch
new file mode 100644
index 0000000..79b57ae
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.8.5-webkit2gtkinjectedbundle-j1.patch
@@ -0,0 +1,22 @@
+2015-08-24 Alexandre Rostovtsev <tetromino@gentoo.org>
+
+ webkit2gtkinjectedbundle requires forwarding headers
+ https://bugs.webkit.org/show_bug.cgi?id=148379
+
+ Fixes GTK build with -j1
+
+ * PlatformGTK.cmake:
+
+Index: Source/WebKit2/PlatformGTK.cmake
+===================================================================
+--- Source/WebKit2/PlatformGTK.cmake (revision 188859)
++++ Source/WebKit2/PlatformGTK.cmake (working copy)
+@@ -860,7 +860,7 @@ include_directories(
+ )
+
+ add_library(webkit2gtkinjectedbundle MODULE "${WEBKIT2_DIR}/WebProcess/gtk/WebGtkInjectedBundleMain.cpp")
+-add_dependencies(webkit2gtkinjectedbundle GObjectDOMBindings)
++add_dependencies(webkit2gtkinjectedbundle GObjectDOMBindings WebKit2-forwarding-headers)
+ add_webkit2_prefix_header(webkit2gtkinjectedbundle)
+
+ # Add ${CMAKE_LIBRARY_OUTPUT_DIRECTORY} to LD_LIBRARY_PATH
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild
new file mode 100644
index 0000000..83ec71c
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.8.5.ebuild
@@ -0,0 +1,285 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+CMAKE_MAKEFILE_GENERATOR="ninja"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+CMAKE_WARN_UNUSED_CLI=yes
+
+inherit check-reqs cmake-utils eutils flag-o-matic gnome2 pax-utils python-any-r1 toolchain-funcs versionator virtualx
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="4/37" # soname version of libwebkit2gtk-4.0
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+
+IUSE="coverage doc +egl +geoloc gles2 +glx +gstreamer +introspection +jit libsecret neon opengl spell wayland +webgl X"
+REQUIRED_USE="
+ geoloc? ( introspection )
+ gles2? ( egl !glx !opengl )
+ introspection? ( gstreamer )
+ webgl? ( ^^ ( gles2 opengl ) )
+ !webgl? ( ?? ( gles2 opengl ) )
+ || ( wayland X )
+"
+
+# Tests fail to link for inexplicable reasons
+# https://bugs.webkit.org/show_bug.cgi?id=148210
+RESTRICT="test"
+
+# use sqlite, svg by default
+# Aqua support in gtk3 is untested
+# gtk2 is needed for plugin process support, should we add a USE flag to configure this?
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/icu-3.8.1-r1:=
+ >=dev-libs/libxml2-2.8:2
+ >=dev-libs/libxslt-1.1.7
+ >=media-libs/fontconfig-2.8:1.0
+ >=media-libs/freetype-2.4.2:2
+ >=media-libs/harfbuzz-0.9.18:=[icu(+)]
+ >=media-libs/libpng-1.4:0=
+ media-libs/libwebp:=
+ >=net-libs/gnutls-3
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.10.2:=
+ >=x11-libs/gtk+-3.14:3[introspection?]
+ x11-libs/libnotify
+ >=x11-libs/pango-1.30.0
+
+ >=x11-libs/gtk+-2.24.10:2
+
+ egl? ( media-libs/mesa[egl] )
+ geoloc? ( >=app-misc/geoclue-2.1.5:2.0 )
+ gles2? ( media-libs/mesa[gles2] )
+ gstreamer? (
+ >=media-libs/gstreamer-1.2:1.0
+ >=media-libs/gst-plugins-base-1.2:1.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.32.0 )
+ libsecret? ( app-crypt/libsecret )
+ opengl? ( virtual/opengl
+ x11-libs/cairo[opengl] )
+ spell? ( >=app-text/enchant-0.22:= )
+ wayland? ( >=x11-libs/gtk+-3.14:3[wayland] )
+ webgl? (
+ || ( x11-libs/cairo[opengl]
+ x11-libs/cairo[gles2]
+ )
+ x11-libs/libXcomposite
+ x11-libs/libXdamage )
+ X? (
+ x11-libs/cairo[X]
+ >=x11-libs/gtk+-3.14:3[X]
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt )
+"
+
+# paxctl needed for bug #407085
+# Need real bison, not yacc
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5.10
+ || (
+ virtual/rubygems[ruby_targets_ruby20]
+ virtual/rubygems[ruby_targets_ruby21]
+ virtual/rubygems[ruby_targets_ruby22]
+ virtual/rubygems[ruby_targets_ruby19]
+ )
+ >=app-accessibility/at-spi2-core-2.5.3
+ >=dev-libs/atk-2.8.0
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/gperf-3.0.1
+ >=sys-devel/bison-2.4.3
+ >=sys-devel/flex-2.5.34
+ || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ geoloc? ( dev-util/gdbus-codegen )
+ introspection? ( jit? ( sys-apps/paxctl ) )
+ test? (
+ dev-lang/python:2.7
+ dev-python/pygobject:3[python_targets_python2_7]
+ x11-themes/hicolor-icon-theme
+ jit? ( sys-apps/paxctl ) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+EPATCH_OPTS="-F 3"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if [[ ${MERGE_TYPE} != "binary" ]] && ! test-flag-CXX -std=c++11; then
+ die "You need at least GCC 4.7.x or Clang >= 3.3 for C++11-specific compiler flags"
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ check-reqs_pkg_setup
+ fi
+
+ [[ ${MERGE_TYPE} = "binary" ]] || python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Debian patches to fix support for some arches
+ # https://bugs.webkit.org/show_bug.cgi?id=129540
+ epatch "${FILESDIR}"/${PN}-2.6.0-{hppa,ia64}-platform.patch
+ # https://bugs.webkit.org/show_bug.cgi?id=129542
+ epatch "${FILESDIR}"/${PN}-2.8.1-ia64-malloc.patch
+
+ # https://bugs.webkit.org/show_bug.cgi?id=148379
+ epatch "${FILESDIR}"/${PN}-2.8.5-webkit2gtkinjectedbundle-j1.patch
+ # plus a couple more
+ epatch "${FILESDIR}"/${PN}-2.8.4-config-options.patch
+ epatch "${FILESDIR}"/${PN}-2.8.4-fix-opengl-off.patch
+ epatch "${FILESDIR}"/${PN}-2.8.4-fix-FindCairoGL.patch
+ epatch "${FILESDIR}"/${PN}-2.8.4-gles2-config.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # Arches without JIT support also need this to really disable it in all places
+ use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61207
+ use arm && replace-flags "-O3" "-O2"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ # --no-keep-memory doesn't work on ia64, bug #502492
+ if ! use ia64; then
+ append-ldflags "-Wl,--no-keep-memory"
+ fi
+ if ! $(tc-getLD) --version | grep -q "GNU gold"; then
+ append-ldflags "-Wl,--reduce-memory-overheads"
+ fi
+
+ # older glibc needs this for INTPTR_MAX, bug #533976
+ if has_version "<sys-libs/glibc-2.18" ; then
+ append-cppflags "-D__STDC_LIMIT_MACROS"
+ fi
+
+ # Multiple rendering bugs on youtube, github, etc without this, bug #547224
+ append-flags $(test-flags -fno-strict-aliasing)
+
+ local ruby_interpreter=""
+
+ if has_version "virtual/rubygems[ruby_targets_ruby22]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby22)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby21)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby20)"
+ else
+ ruby_interpreter="-DRUBY_EXECUTABLE=$(type -P ruby19)"
+ fi
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ #
+ # FTL_JIT requires llvm
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test API_TESTS)
+ $(cmake-utils_use_enable doc GTKDOC)
+ $(cmake-utils_use_enable geoloc GEOLOCATION)
+ $(cmake-utils_use_find_package gles2 OpenGLES2)
+ $(cmake-utils_use_enable gles2 GLES2)
+ $(cmake-utils_use_enable gstreamer VIDEO)
+ $(cmake-utils_use_enable gstreamer WEB_AUDIO)
+ $(cmake-utils_use_enable introspection)
+ $(cmake-utils_use_enable jit)
+ $(cmake-utils_use_enable libsecret CREDENTIAL_STORAGE)
+ $(cmake-utils_use_enable spell SPELLCHECK SPELLCHECK)
+ $(cmake-utils_use_enable wayland WAYLAND_TARGET)
+ $(cmake-utils_use_enable webgl WEBGL)
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_enable X X11_TARGET)
+ -DCMAKE_BUILD_TYPE=Release
+ -DPORT=GTK
+ -DENABLE_PLUGIN_PROCESS_GTK2=ON
+ ${ruby_interpreter}
+ )
+
+ # workaround for busted argument handling
+ if use opengl ; then
+ mycmakeargs+=( -WTF_USE_OPENGL=1 )
+ if use glx ; then
+ mycmakeargs+=( -WTF_USE_GLX=1 )
+ fi
+ else
+ mycmakeargs+=( -WTF_USE_OPENGL=0 )
+ mycmakeargs+=( -WTF_USE_GLX=0 )
+ fi
+
+ # yes, this is stupid, but webkit is stupider...
+ if use arm ; then
+ append-cppflags "-D_ARM_"
+ append-cppflags "-D__ARM_PCS_VFP"
+ if [[ ${CHOST} == armv7* ]] ; then
+ append-cppflags "-D__ARM_ARCH_7A__"
+ fi
+ if use neon ; then
+ append-cppflags "-D__ARM_NEON__"
+ fi
+ fi
+
+ if $(tc-getLD) --version | grep -q "GNU gold"; then
+ mycmakeargs+=( -DUSE_LD_GOLD=ON )
+ else
+ mycmakeargs+=( -DUSE_LD_GOLD=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ # Prevents test failures on PaX systems
+ use jit && pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
+
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Prevents crashes on PaX systems, bug #522808
+ use jit && pax-mark m "${ED}usr/bin/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
+ pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"{,2}
+}