aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-07-06 19:11:19 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-07-06 19:11:19 -0700
commitc79c16a4ee15f1663fe4ff6ff2298f67abc2b01a (patch)
treef06f398bb41bd8e2336432926941f70b3924a424 /net-libs/webkit-gtk
parentrenamed drm-rpi kernel ebuild to something more appropriate (diff)
downloadarm-c79c16a4ee15f1663fe4ff6ff2298f67abc2b01a.tar.gz
arm-c79c16a4ee15f1663fe4ff6ff2298f67abc2b01a.tar.bz2
arm-c79c16a4ee15f1663fe4ff6ff2298f67abc2b01a.zip
updated webkit-gtk deps for cairo
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/Manifest1
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.6.0-hppa-platform.patch34
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.6.0-ia64-platform.patch26
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-2.8.1-ia64-malloc.patch31
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.8.3.ebuild240
5 files changed, 332 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/Manifest b/net-libs/webkit-gtk/Manifest
index a71a3c7..3bd4300 100644
--- a/net-libs/webkit-gtk/Manifest
+++ b/net-libs/webkit-gtk/Manifest
@@ -7,3 +7,4 @@ DIST webkitgtk-2.4.6.tar.xz 9862200 SHA256 6fef4aa8d4a2668e03ea15472a71396ea7b77
DIST webkitgtk-2.4.7.tar.xz 9826208 SHA256 f5cf26e39abf1d6b2d25f1398348fef6bbe6c03fb4f99e11c569091c05197d38 SHA512 1ba2371b34e40e078f6d85774e171f559e4f269ac80f63c56e2e7612e2ec3a41db0f5999af028b1b93657634fcdfcc3612e1a55eeeec2578fe448bd0861b0729 WHIRLPOOL 1cd8382e91efdce9d3654fe16de2f664b1f874ed7e9f811e5d652dd96e7269a48492f44ccbb1cd46e36d41b92188466b68a6e3e009e8dd037dce35ec9582f3d8
DIST webkitgtk-2.4.8.tar.xz 9827632 SHA256 68f11559cb178679ca92acc9e3a3d7febede7acb7b98afd7fb761875bbc6bd23 SHA512 31b8b87142730aa27e5bd4fe85b0de2116fd492ef469592512c185d60df428a9913d6c2738ce57439bf9db10864ed9c121ddbc2a4da2f715818a70885c81c0de WHIRLPOOL 851e3973c00096dd3a98e64bfa9f9f0f278c3513656af9a9aa72442cd6c594119adefafa6c06d05e431ec77bf6e9f1e10432e9b6895d777adfe2952843602ef2
DIST webkitgtk-2.4.9.tar.xz 9840740 SHA256 afdf29e7828816cad0be2604cf19421e96d96bf493987328ffc8813bb20ac564 SHA512 5dfe5c31e0fcbab5e468a18e08918a439b214dcd620386fa32d35e9110e479b552a4b0b88a1bb8574b34445d5cc5219be349feded32fc1d2791a6c6279d61f98 WHIRLPOOL 26141cd12878bc8136ecffc1636fdcb037f342e5c27c8c557117564af9d1673af84c8c4fd10d3fdbe890bdf183791b18a210f57de9750422959a45c60390076c
+DIST webkitgtk-2.8.3.tar.xz 10437676 SHA256 b3de60c8676ed54bb3d6201c742bbd702ee176fdfef5ca06f2fc514783792f16 SHA512 29a8f17d921a3015cea8e1e156c42b8f7d5504643157381888c9613a706070b2bde1435cc83048969cc24b525a3f7cd27a493d9636a4bace6bac921b2179874d WHIRLPOOL 03c6f1206203f79ae69c50dab085872a9920982ac556b7e611e114c4d5753ec31d7c6bf3ccf62ae08929886a02bff001a8ac74ad8a4e0ed96879f74539c0c3c4
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.6.0-hppa-platform.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.6.0-hppa-platform.patch
new file mode 100644
index 0000000..0623582
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.6.0-hppa-platform.patch
@@ -0,0 +1,34 @@
+From 8ba68225e9ad35958197aacc03a7a1716741b14c Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 19 Oct 2014 19:37:40 +0200
+Subject: [PATCH 1/4] Fix support for HPPA
+
+Debian patches to fix support for some arches
+https://bugs.webkit.org/show_bug.cgi?id=129540
+---
+ Source/WTF/wtf/Platform.h | 9 +++++++++
+ 1 file changed, 9 insertions(+)
+
+diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
+index 7712ddb..65f1379 100644
+--- a/Source/WTF/wtf/Platform.h
++++ b/Source/WTF/wtf/Platform.h
+@@ -71,6 +71,15 @@
+ #define WTF_CPU_BIG_ENDIAN 1
+ #endif
+
++/* CPU(HPPA) - HP PARISC */
++#if defined(__hppa__)
++#define WTF_CPU_HPPA 1
++#define WTF_CPU_BIG_ENDIAN 1
++#define ENABLE_JIT 0
++#define ENABLE_YARR_JIT 0
++#define ENABLE_ASSEMBLER 0
++#endif
++
+ /* CPU(IA64) - Itanium / IA-64 */
+ #if defined(__ia64__)
+ #define WTF_CPU_IA64 1
+--
+2.1.2
+
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.6.0-ia64-platform.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.6.0-ia64-platform.patch
new file mode 100644
index 0000000..57587e9
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.6.0-ia64-platform.patch
@@ -0,0 +1,26 @@
+From d98ac8c1040318e648f8417fa5ca6df66cc00b35 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 19 Oct 2014 19:38:18 +0200
+Subject: [PATCH 2/4] Fix support for IA64
+
+---
+ Source/WTF/wtf/Platform.h | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
+index 65f1379..d9afcd7 100644
+--- a/Source/WTF/wtf/Platform.h
++++ b/Source/WTF/wtf/Platform.h
+@@ -87,6 +87,9 @@
+ #if !defined(__LP64__)
+ #define WTF_CPU_IA64_32 1
+ #endif
++#define ENABLE_JIT 0
++#define ENABLE_YARR_JIT 0
++#define ENABLE_ASSEMBLER 0
+ #endif
+
+ /* CPU(MIPS) - MIPS 32-bit */
+--
+2.1.2
+
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-2.8.1-ia64-malloc.patch b/net-libs/webkit-gtk/files/webkit-gtk-2.8.1-ia64-malloc.patch
new file mode 100644
index 0000000..57be875
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-2.8.1-ia64-malloc.patch
@@ -0,0 +1,31 @@
+From 9348d1c7fbbd9fcbb1702c0c6d81c723ec0b6879 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sun, 19 Oct 2014 19:40:21 +0200
+Subject: [PATCH 3/4] Use system malloc for IA64
+
+https://bugs.webkit.org/show_bug.cgi?id=129542
+---
+ Source/WTF/wtf/Platform.h | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/Source/WTF/wtf/Platform.h b/Source/WTF/wtf/Platform.h
+index d9afcd7..c4cf1d2 100644
+--- a/Source/WTF/wtf/Platform.h
++++ b/Source/WTF/wtf/Platform.h
+@@ -662,6 +662,13 @@
+ #endif
+ #endif /* !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32_64) */
+
++/* FIXME: The fast malloc implementation is broken on Itanium / IA64 because
++ some memory barriers are missing in the thread-unsafe code around the
++ pagemap_cache_ object. */
++#if CPU(IA64) || CPU(IA64_32)
++#define USE_SYSTEM_MALLOC 1
++#endif
++
+ /* The JIT is enabled by default on all x86, x86-64, ARM & MIPS platforms except ARMv7k. */
+ #if !defined(ENABLE_JIT) \
+ && (CPU(X86) || CPU(X86_64) || CPU(ARM) || CPU(ARM64) || CPU(MIPS)) \
+--
+2.1.2
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.8.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.8.3.ebuild
new file mode 100644
index 0000000..928ae45
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-2.8.3.ebuild
@@ -0,0 +1,240 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-2.8.3.ebuild,v 1.1 2015/06/09 14:34:30 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit check-reqs cmake-utils eutils flag-o-matic gnome2 pax-utils python-any-r1 toolchain-funcs versionator virtualx
+
+MY_P="webkitgtk-${PV}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkitgtk.org/"
+SRC_URI="http://www.webkitgtk.org/releases/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2+ BSD"
+SLOT="4/37" # soname version of libwebkit2gtk-4.0
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+
+IUSE="coverage doc +egl +geoloc gles2 +gstreamer +introspection +jit libsecret +opengl spell wayland +webgl X"
+REQUIRED_USE="
+ geoloc? ( introspection )
+ gles2? ( egl )
+ introspection? ( gstreamer )
+ webgl? ( ^^ ( gles2 opengl ) )
+ !webgl? ( ?? ( gles2 opengl ) )
+ || ( wayland X )
+"
+
+# use sqlite, svg by default
+# Aqua support in gtk3 is untested
+# gtk2 is needed for plugin process support, should we add a USE flag to configure this?
+RDEPEND="
+ dev-db/sqlite:3=
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/icu-3.8.1-r1:=
+ >=dev-libs/libxml2-2.8:2
+ >=dev-libs/libxslt-1.1.7
+ >=media-libs/fontconfig-2.8:1.0
+ >=media-libs/freetype-2.4.2:2
+ >=media-libs/harfbuzz-0.9.18:=[icu(+)]
+ >=media-libs/libpng-1.4:0=
+ media-libs/libwebp:=
+ >=net-libs/gnutls-3
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ virtual/jpeg:0=
+ >=x11-libs/cairo-1.10.2:=
+ >=x11-libs/gtk+-3.14:3[introspection?]
+ x11-libs/libnotify
+ >=x11-libs/pango-1.30.0
+
+ >=x11-libs/gtk+-2.24.10:2
+
+ egl? ( media-libs/mesa[egl] )
+ geoloc? ( >=app-misc/geoclue-2.1.5:2.0 )
+ gles2? ( media-libs/mesa[gles2] )
+ gstreamer? (
+ >=media-libs/gstreamer-1.2:1.0
+ >=media-libs/gst-plugins-base-1.2:1.0 )
+ introspection? ( >=dev-libs/gobject-introspection-1.32.0 )
+ libsecret? ( app-crypt/libsecret )
+ opengl? ( virtual/opengl )
+ spell? ( >=app-text/enchant-0.22:= )
+ wayland? ( >=x11-libs/gtk+-3.14:3[wayland] )
+ webgl? (
+ || ( x11-libs/cairo[opengl]
+ x11-libs/cairo[gles2]
+ )
+ x11-libs/libXcomposite
+ x11-libs/libXdamage )
+ X? (
+ x11-libs/cairo[X]
+ >=x11-libs/gtk+-3.14:3[X]
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt )
+"
+
+# paxctl needed for bug #407085
+# Need real bison, not yacc
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5.10
+ || (
+ virtual/rubygems[ruby_targets_ruby20]
+ virtual/rubygems[ruby_targets_ruby21]
+ virtual/rubygems[ruby_targets_ruby22]
+ virtual/rubygems[ruby_targets_ruby19]
+ )
+ >=app-accessibility/at-spi2-core-2.5.3
+ >=dev-libs/atk-2.8.0
+ >=dev-util/gtk-doc-am-1.10
+ >=dev-util/gperf-3.0.1
+ >=sys-devel/bison-2.4.3
+ >=sys-devel/flex-2.5.34
+ || ( >=sys-devel/gcc-4.7 >=sys-devel/clang-3.3 )
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ geoloc? ( dev-util/gdbus-codegen )
+ introspection? ( jit? ( sys-apps/paxctl ) )
+ test? (
+ dev-lang/python:2.7
+ dev-python/pygobject:3[python_targets_python2_7]
+ x11-themes/hicolor-icon-theme
+ jit? ( sys-apps/paxctl ) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+CHECKREQS_DISK_BUILD="18G" # and even this might not be enough, bug #417307
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && is-flagq "-g*" && ! is-flagq "-g*0" ; then
+ einfo "Checking for sufficient disk space to build ${PN} with debugging CFLAGS"
+ check-reqs_pkg_pretend
+ fi
+
+ if ! test-flag-CXX -std=c++11; then
+ die "You need at least GCC 4.7.x or Clang >= 3.3 for C++11-specific compiler flags"
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ check-reqs_pkg_setup
+ fi
+
+ [[ ${MERGE_TYPE} = "binary" ]] || python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Debian patches to fix support for some arches
+ # https://bugs.webkit.org/show_bug.cgi?id=129540
+ epatch "${FILESDIR}"/${PN}-2.6.0-{hppa,ia64}-platform.patch
+ # https://bugs.webkit.org/show_bug.cgi?id=129542
+ epatch "${FILESDIR}"/${PN}-2.8.1-ia64-malloc.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Respect CC, otherwise fails on prefix #395875
+ tc-export CC
+
+ # Arches without JIT support also need this to really disable it in all places
+ use jit || append-cppflags -DENABLE_JIT=0 -DENABLE_YARR_JIT=0 -DENABLE_ASSEMBLER=0
+
+ # It does not compile on alpha without this in LDFLAGS
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648761
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ # Sigbuses on SPARC with mcpu and co., bug #???
+ use sparc && filter-flags "-mvis"
+
+ # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
+ use ppc64 && append-flags "-mminimal-toc"
+
+ # Try to use less memory, bug #469942 (see Fedora .spec for reference)
+ # --no-keep-memory doesn't work on ia64, bug #502492
+ if ! use ia64; then
+ append-ldflags "-Wl,--no-keep-memory"
+ fi
+ if ! $(tc-getLD) --version | grep -q "GNU gold"; then
+ append-ldflags "-Wl,--reduce-memory-overheads"
+ fi
+
+ # older glibc needs this for INTPTR_MAX, bug #533976
+ if has_version "<sys-libs/glibc-2.18" ; then
+ append-cppflags "-D__STDC_LIMIT_MACROS"
+ fi
+
+ # Multiple rendering bugs on youtube, github, etc without this, bug #547224
+ append-flags $(test-flags -fno-strict-aliasing)
+
+ local ruby_interpreter=""
+
+ if has_version "virtual/rubygems[ruby_targets_ruby22]"; then
+ ruby_interpreter="RUBY=$(type -P ruby22)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby21]"; then
+ ruby_interpreter="RUBY=$(type -P ruby21)"
+ elif has_version "virtual/rubygems[ruby_targets_ruby20]"; then
+ ruby_interpreter="RUBY=$(type -P ruby20)"
+ else
+ ruby_interpreter="RUBY=$(type -P ruby19)"
+ fi
+
+ # TODO: Check Web Audio support
+ # should somehow let user select between them?
+ #
+ # FTL_JIT requires llvm
+ local mycmakeargs=(
+ $(cmake-utils_use_enable test API_TESTS)
+ $(cmake-utils_use_enable doc GTKDOC)
+ $(cmake-utils_use_enable geoloc GEOLOCATION)
+ $(cmake-utils_use_find_package gles2 OpenGLES2)
+ $(cmake-utils_use_enable gstreamer VIDEO)
+ $(cmake-utils_use_enable gstreamer WEB_AUDIO)
+ $(cmake-utils_use_enable introspection)
+ $(cmake-utils_use_enable jit)
+ $(cmake-utils_use_enable libsecret CREDENTIAL_STORAGE)
+ $(cmake-utils_use_enable spell SPELLCHECK SPELLCHECK)
+ $(cmake-utils_use_enable wayland WAYLAND_TARGET)
+ $(cmake-utils_use_enable webgl WEBGL)
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_enable X X11_TARGET)
+ -DCMAKE_BUILD_TYPE=Release
+ -DPORT=GTK
+ -DENABLE_PLUGIN_PROCESS_GTK2=ON
+ ${ruby_interpreter}
+ )
+ if $(tc-getLD) --version | grep -q "GNU gold"; then
+ mycmakeargs+=( -DUSE_LD_GOLD=ON )
+ else
+ mycmakeargs+=( -DUSE_LD_GOLD=OFF )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_test() {
+ # Prevents test failures on PaX systems
+ use jit && pax-mark m $(list-paxables Programs/*[Tt]ests/*) # Programs/unittests/.libs/test*
+
+ cmake-utils_src_test
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Prevents crashes on PaX systems, bug #522808
+ use jit && pax-mark m "${ED}usr/bin/jsc" "${ED}usr/libexec/webkit2gtk-4.0/WebKitWebProcess"
+ pax-mark m "${ED}usr/libexec/webkit2gtk-4.0/WebKitPluginProcess"{,2}
+}