summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/ChangeLog8
-rw-r--r--x11-wm/blackbox/blackbox-0.62.1-r1.ebuild64
-rwxr-xr-xx11-wm/blackbox/files/blackbox2
-rw-r--r--x11-wm/blackbox/files/digest-blackbox-0.62.1-r11
4 files changed, 74 insertions, 1 deletions
diff --git a/x11-wm/blackbox/ChangeLog b/x11-wm/blackbox/ChangeLog
index 9461778c3773..2d4833e732d9 100644
--- a/x11-wm/blackbox/ChangeLog
+++ b/x11-wm/blackbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/blackbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.2 2002/02/02 11:48:55 aeoo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/ChangeLog,v 1.3 2002/02/14 22:04:04 danarmak Exp $
+
+*blackbox-0.62.1-r1 (14 Feb 2002)
+
+ 14 Feb 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+ Added /etc/X11/Sessions/blackbox, which adds blackbox to the auto-updated session
+ list in kdm and gdm.
*blackbox-0.62.1 (2 Feb 2002)
diff --git a/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild b/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild
new file mode 100644
index 000000000000..4784b65f82b4
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# Modified by Matthew Jimenez
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/blackbox/blackbox-0.62.1-r1.ebuild,v 1.1 2002/02/14 22:01:54 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small, fast, full-featured window manager for X"
+SRC_URI="http://prdownloads.sourceforge.net/blackboxwm/${P}.tar.gz"
+
+# Old homepage:
+# HOMEPAGE="http://blackbox.alug.org/"
+
+# This is the new home page for blackbox now that Sean Perry has taken the
+# project over, but the page is currently non-existent
+
+HOMEPAGE="http://blackboxwm.sf.net/"
+
+
+DEPEND=">=x11-base/xfree-4.0"
+
+src_compile() {
+ local myconf
+ use nls || myconf="$myconf --disable-nls"
+
+ ./configure --build=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/X11/blackbox \
+ $myconf || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/X11/blackbox \
+ install || die
+
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/blackbox
+
+}
+
+pkg_postinst() {
+ #notify user about the new share dir
+ if [ -d /usr/share/Blackbox ]
+ then
+ echo
+ echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ echo "! Blackbox no longer uses /usr/share/Blackbox as the !"
+ echo "! default share directory to contain styles and menus. !"
+ echo "! The default directory is now /usr/share/blackbox !"
+ echo "! Please move any files in /usr/share/Blackbox that you !"
+ echo "! wish to keep (personal styles and your menu) into the !"
+ echo "! new directory and modify your menu files to point all !"
+ echo "! listed paths to the new directory. !"
+ echo "! Also, be sure to update the paths in each user's !"
+ echo "! .blackboxrc file found in their home directory. !"
+ echo "!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!"
+ echo
+ fi
+}
+
diff --git a/x11-wm/blackbox/files/blackbox b/x11-wm/blackbox/files/blackbox
new file mode 100755
index 000000000000..1bb6055dec6d
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/blackbox
diff --git a/x11-wm/blackbox/files/digest-blackbox-0.62.1-r1 b/x11-wm/blackbox/files/digest-blackbox-0.62.1-r1
new file mode 100644
index 000000000000..0e8940778b7c
--- /dev/null
+++ b/x11-wm/blackbox/files/digest-blackbox-0.62.1-r1
@@ -0,0 +1 @@
+MD5 a188b0bb144eb239bac98e781f1611d9 blackbox-0.62.1.tar.gz 299604