summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmium/wmium-1.0.8.ebuild')
-rw-r--r--x11-plugins/wmium/wmium-1.0.8.ebuild37
1 files changed, 18 insertions, 19 deletions
diff --git a/x11-plugins/wmium/wmium-1.0.8.ebuild b/x11-plugins/wmium/wmium-1.0.8.ebuild
index c1616bda9f28..8d1bfcb2ca1f 100644
--- a/x11-plugins/wmium/wmium-1.0.8.ebuild
+++ b/x11-plugins/wmium/wmium-1.0.8.ebuild
@@ -1,46 +1,45 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/wmium-1.0.8.ebuild,v 1.3 2004/04/13 18:27:58 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/wmium-1.0.8.ebuild,v 1.4 2004/06/23 22:37:29 agriffis Exp $
-DESCRIPTION="WindowMaker DockApp/Grellm2 pluggin that fetches the DSL usage information for Australian ISP Internode"
+IUSE="gtk"
+DESCRIPTION="WindowMaker DockApp/Grellm2 pluggin that fetches the DSL usage information for Australian ISP Internode"
HOMEPAGE="http://www.earthmagic.org/?software"
-
SRC_URI="http://www.earthmagic.org/files/${P}.tar.gz"
-
LICENSE="GPL-2"
-
SLOT="0"
-
KEYWORDS="x86"
-IUSE="gtk"
-
DEPEND="virtual/glibc
virtual/x11
media-libs/xpm
dev-libs/openssl
- gtk? ( >=x11-libs/gtk+-2* )
- gtk? ( app-admin/gkrellm )
- gtk? ( dev-util/pkgconfig )"
+ gtk? (
+ >=x11-libs/gtk+-2*
+ app-admin/gkrellm
+ dev-util/pkgconfig
+ )"
RDEPEND="virtual/glibc
virtual/x11
media-libs/xpm
dev-libs/openssl
- gtk? ( >=x11-libs/gtk+-2* )
- gtk? ( app-admin/gkrellm )
+ gtk? (
+ >=x11-libs/gtk+-2*
+ app-admin/gkrellm
+ )
!gtk? ( x11-wm/windowmaker )"
src_compile() {
-
- emake build || die "Cannot make ${P}"
- use gtk && emake build-gk2
+ emake build || die
+ if use gtk; then
+ emake build-gk2 || die
+ fi
}
src_install() {
-
- if [ `use gtk` ]; then
+ if use gtk; then
exeinto /usr/lib/gkrellm2/plugins
doexe src-gk2/wmium-gk2.so
fi
@@ -56,6 +55,6 @@ src_install() {
einfo "To configure look at the /usr/share/doc/${PF}/dot.wmiumrc.sample"
einfo "(if using /usr/bin/wmium with WINDOWMAKER ONLY)"
einfo ""
- einfo " or use the preferences within gkrellm2"
+ einfo "or use the preferences within gkrellm2"
}