summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild')
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild
index b8e86f8d9f82..40bd8ded4009 100644
--- a/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild,v 1.2 2008/09/02 22:26:40 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-latex/pidgin-latex-1.2.1.ebuild,v 1.3 2009/08/16 09:10:44 betelgeuse Exp $
+
+EAPI="2"
inherit flag-o-matic multilib eutils
@@ -13,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="net-im/pidgin
+DEPEND="net-im/pidgin[gtk]
>=x11-libs/gtk+-2"
RDEPEND="${DEPEND}
virtual/latex-base
@@ -21,13 +23,6 @@ RDEPEND="${DEPEND}
S=${WORKDIR}/${PN}
-pkg_setup() {
- if ! built_with_use net-im/pidgin gtk; then
- eerror "You need to compile net-im/pidgin with USE=gtk"
- die "Missing gtk USE flag on net-im/pidgin"
- fi
-}
-
src_compile()
{
append-flags -fPIC
@@ -36,7 +31,7 @@ src_compile()
src_install()
{
- make LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX="${D}/usr" \
+ emake LIB_INSTALL_DIR="${D}/usr/$(get_libdir)/pidgin" install PREFIX="${D}/usr" \
|| die "make install failed"
- dodoc README CHANGELOG TODO
+ dodoc README CHANGELOG TODO || die
}