summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsel/xsel-1.2.0.ebuild')
-rw-r--r--x11-misc/xsel/xsel-1.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-1.2.0.ebuild b/x11-misc/xsel/xsel-1.2.0.ebuild
new file mode 100644
index 000000000000..efd6b75bcf27
--- /dev/null
+++ b/x11-misc/xsel/xsel-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsel/xsel-1.2.0.ebuild,v 1.1 2009/05/04 09:18:37 nelchael Exp $
+
+DESCRIPTION="XSel is a command-line program for getting and setting the contents of the X selection."
+HOMEPAGE="http://www.vergenet.net/~conrad/software/xsel"
+SRC_URI="http://www.vergenet.net/~conrad/software/${PN}/download/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-libs/libXt"
+
+src_compile() {
+ econf --disable-dependency-tracking
+ emake CFLAGS="${CFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README
+}