summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/tkhylafax/tkhylafax-3.2.ebuild')
-rw-r--r--x11-misc/tkhylafax/tkhylafax-3.2.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/x11-misc/tkhylafax/tkhylafax-3.2.ebuild b/x11-misc/tkhylafax/tkhylafax-3.2.ebuild
index 4d5b94f13f81..27a42a9eb61c 100644
--- a/x11-misc/tkhylafax/tkhylafax-3.2.ebuild
+++ b/x11-misc/tkhylafax/tkhylafax-3.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tkhylafax/tkhylafax-3.2.ebuild,v 1.7 2004/06/24 22:34:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tkhylafax/tkhylafax-3.2.ebuild,v 1.8 2010/07/21 14:52:44 ssuominen Exp $
# This is a new ebuild for the tkHylafax client. This code has barely been
# touched in several years, but it works well enough, and is the only
@@ -8,45 +8,39 @@
inherit eutils
-IUSE=""
-
DESCRIPTION="Tk-based client for HylaFAX(tm) with rolodex and batch faxing support."
HOMEPAGE="http://www.hylafax.org"
SRC_URI="ftp://ftp.hylafax.org/contrib/tkhylafax/${P}.tar.gz"
-SLOT="0"
LICENSE="freedist"
-KEYWORDS="x86 ~ppc"
+SLOT="0"
+KEYWORDS="~ppc x86"
+IUSE=""
DEPEND="dev-lang/tk
net-misc/hylafax"
-
RDEPEND="${DEPEND}
app-text/gv"
src_unpack() {
unpack ${A}
- cd ${WORKDIR}/${P}
- epatch ${FILESDIR}/${PF}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PF}-gentoo.patch
}
src_compile() {
- # no 'econf' here because it only uses a static Makefile :(
make PREFIX=/usr build || die
}
src_install() {
-
dodir /usr/bin /usr/lib/tkhylafax-3.2 /usr/share/man/man1
- # no 'emake' for the same reason.
- make PREFIX=${D}/usr install.lib install.man install.tkhylafax || die
+ make PREFIX="${D}/usr" install.lib install.man install.tkhylafax || die
dodoc INSTALL CHANGES VERSION tkhylafax-3.2.README
}
pkg_postinst() {
-
cd /usr/lib/tkhylafax-3.2
echo 'auto_mkindex /usr/lib/tkhylafax-3.2 *.tcl *.t' | /usr/bin/tclsh