summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-proxy/squidguard/files/squidguard-1.2.0-db42.patch')
-rw-r--r--www-proxy/squidguard/files/squidguard-1.2.0-db42.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-proxy/squidguard/files/squidguard-1.2.0-db42.patch b/www-proxy/squidguard/files/squidguard-1.2.0-db42.patch
new file mode 100644
index 000000000000..bc7e567ac1a5
--- /dev/null
+++ b/www-proxy/squidguard/files/squidguard-1.2.0-db42.patch
@@ -0,0 +1,41 @@
+--- squidGuard-1.2.0/configure.in.chris 2004-08-25 02:44:38 +0000
++++ squidGuard-1.2.0/configure.in 2004-08-25 02:46:18 +0000
+@@ -73,7 +73,8 @@
+
+ AC_CHECK_LIB(db,db_version,,
+ AC_CHECK_LIB(db,db_version_4000,,
+-AC_CHECK_LIB(db,db_version_4001,,[
++AC_CHECK_LIB(db,db_version_4001,,
++AC_CHECK_LIB(db,db_version_4002,,[
+ echo
+ echo "** The Berkley DB library is required for squidGuard"
+ echo " to compile. Get it from http://www.sleepycat.com"
+@@ -82,7 +82,7 @@
+ echo " its location. (default is $dbprefix/BerkeleyDB)"
+ echo
+ exit 1
+- ])))
++ ]))))
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+--- squidGuard-1.2.0/src/sgDb.c.chris 2004-08-25 02:46:44 +0000
++++ squidGuard-1.2.0/src/sgDb.c 2004-08-25 02:47:01 +0000
+@@ -98,7 +98,7 @@
+ if(createdb)
+ flag = flag | DB_TRUNCATE;
+ if ((ret =
+-#if DB_VERSION_MINOR == 1
++#if DB_VERSION_MINOR == 1 || DB_VERSION_MINOR == 2
+ Db->dbp->open(Db->dbp, NULL, dbfile, NULL, DB_BTREE, flag, 0664)) != 0) {
+ #else
+ Db->dbp->open(Db->dbp, dbfile, NULL, DB_BTREE, flag, 0664)) != 0) {
+@@ -108,7 +108,7 @@
+ }
+ } else {
+ if ((ret =
+-#if DB_VERSION_MINOR == 1
++#if DB_VERSION_MINOR == 1 || DB_VERSION_MINOR == 2
+ Db->dbp->open(Db->dbp, NULL, dbfile, NULL, DB_BTREE, DB_CREATE, 0664)) != 0) {
+ #else
+ Db->dbp->open(Db->dbp, dbfile, NULL, DB_BTREE, DB_CREATE, 0664)) != 0) {