summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-40.0.2214.93.ebuild')
-rw-r--r--www-client/chromium/chromium-40.0.2214.93.ebuild26
1 files changed, 23 insertions, 3 deletions
diff --git a/www-client/chromium/chromium-40.0.2214.93.ebuild b/www-client/chromium/chromium-40.0.2214.93.ebuild
index 9550de87d5ea..96740154fe2a 100644
--- a/www-client/chromium/chromium-40.0.2214.93.ebuild
+++ b/www-client/chromium/chromium-40.0.2214.93.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.93.ebuild,v 1.3 2015/02/09 00:50:13 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-40.0.2214.93.ebuild,v 1.4 2015/02/09 10:39:40 zx2c4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -19,7 +19,7 @@ SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc"
+IUSE="bindist cups gnome gnome-keyring kerberos neon pic pulseaudio selinux +tcmalloc widevine"
RESTRICT="!bindist? ( bindist )"
# Native Client binaries are compiled with different set of flags, bug #452066.
@@ -94,7 +94,11 @@ DEPEND="${RDEPEND}
sys-apps/hwids[usb(+)]
>=sys-devel/bison-2.4.3
sys-devel/flex
- virtual/pkgconfig"
+ virtual/pkgconfig
+ widevine? ( www-plugins/chrome-binary-plugins[widevine] )"
+ # We build-dep on having widevine, because the patch
+ # below must extract the current version.
+
# For nvidia-drivers blocker, see bug #413637 .
RDEPEND+="
!=www-client/chromium-9999
@@ -187,6 +191,19 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-system-jinja-r7.patch"
epatch "${FILESDIR}/${PN}-cups-r0.patch"
+ if use widevine; then
+ local WIDEVINE_VERSION="$(< "${ROOT}/usr/$(get_libdir)/chromium-browser/widevine.version")"
+ [[ -z $WIDEVINE_VERSION ]] && die "Could not determine Widevine version."
+ sed -e "s/@WIDEVINE_VERSION@/${WIDEVINE_VERSION}/" "${FILESDIR}/${PN}-widevine.patch" > "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ epatch "${T}/${PN}-widevine-${WIDEVINE_VERSION}.patch"
+ local WIDEVINE_SUPPORTED_ARCHS="x64 ia32"
+ local arch
+ for arch in $WIDEVINE_SUPPORTED_ARCHS; do
+ mkdir -p third_party/widevine/cdm/linux/$arch
+ cp "${ROOT}/usr/$(get_libdir)/chromium-browser/libwidevinecdm.so" third_party/widevine/cdm/widevine_cdm_*.h third_party/widevine/cdm/linux/$arch/ || die "Could not copy headers for Widevine."
+ done
+ fi
+
epatch_user
# Remove most bundled libraries. Some are still needed.
@@ -571,6 +588,9 @@ src_install() {
doexe out/Release/libffmpegsumo.so || die
doexe out/Release/libpdf.so || die
+ if use widevine; then
+ doexe out/Release/libwidevinecdmadapter.so || die
+ fi
# Install icons and desktop entry.
local branding size