summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/lxr/ChangeLog14
-rw-r--r--www-apps/lxr/lxr-0.9.5.ebuild25
-rw-r--r--www-apps/mambo/ChangeLog8
-rw-r--r--www-apps/mambo/mambo-4.6.3-r1.ebuild14
4 files changed, 47 insertions, 14 deletions
diff --git a/www-apps/lxr/ChangeLog b/www-apps/lxr/ChangeLog
index 43485fa22c3b..3a0c68b5393c 100644
--- a/www-apps/lxr/ChangeLog
+++ b/www-apps/lxr/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for www-apps/lxr
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/ChangeLog,v 1.14 2007/07/29 17:28:37 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/ChangeLog,v 1.15 2008/02/03 17:04:57 hollow Exp $
+
+ 03 Feb 2008; Benedikt Böhm <hollow@gentoo.org> lxr-0.9.5.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> lxr-0.9.5.ebuild:
+ Fix apache dependency wrt Bug 208584. Remove incorrect dependency on
+ dev-db/postgresql. Set WEBAPP_MANUAL_SLOT since otherwise this will
+ obviously collide on the perl modules stuff. Call webapp eclass
+ functions explicitely so that this does not get messed up by
+ perl-module exported functions.
29 Jul 2007; Christian Heim <phreak@gentoo.org> lxr-0.9.5.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to
diff --git a/www-apps/lxr/lxr-0.9.5.ebuild b/www-apps/lxr/lxr-0.9.5.ebuild
index 76762367644d..a2e33b968f99 100644
--- a/www-apps/lxr/lxr-0.9.5.ebuild
+++ b/www-apps/lxr/lxr-0.9.5.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.9.5.ebuild,v 1.4 2007/07/29 17:28:37 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/lxr/lxr-0.9.5.ebuild,v 1.5 2008/02/03 17:04:57 hollow Exp $
-inherit perl-module webapp multilib eutils
+inherit perl-module webapp multilib eutils depend.apache
DESCRIPTION="general purpose source code indexer and cross-referener with a web-based frontend"
HOMEPAGE="http://sourceforge.net/projects/lxr"
@@ -11,17 +11,24 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="cvs freetext mysql postgres"
+WEBAPP_MANUAL_SLOT="yes"
+SLOT="0"
RDEPEND="dev-util/ctags
- www-servers/apache
freetext? ( >=www-apps/swish-e-2.1 )
dev-lang/perl
dev-perl/DBI
dev-perl/File-MMagic
cvs? ( app-text/rcs )
- postgres? ( dev-db/postgresql dev-perl/DBD-Pg )
+ postgres? ( dev-perl/DBD-Pg )
mysql? ( dev-perl/DBD-mysql )"
+need_apache2
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -69,3 +76,11 @@ src_install() {
webapp_hook_script "${FILESDIR}"/reconfig
webapp_src_install
}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+}
+
+pkg_prerm() {
+ webapp_pkg_prerm
+}
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
index aff400300de1..c7836fe7e557 100644
--- a/www-apps/mambo/ChangeLog
+++ b/www-apps/mambo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mambo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.34 2008/01/27 20:41:44 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.35 2008/02/03 17:08:49 hollow Exp $
+
+ 03 Feb 2008; Benedikt Böhm <hollow@gentoo.org> mambo-4.6.3-r1.ebuild:
+ merge from webapps overlay wrt #208584
+
+ 02 Feb 2008; Jakub Moc <jakub@gentoo.org> mambo-4.6.3-r1.ebuild:
+ Fix apache dependency wrt Bug 208584 and improve checks for PHP features.
*mambo-4.6.3-r1 (27 Jan 2008)
diff --git a/www-apps/mambo/mambo-4.6.3-r1.ebuild b/www-apps/mambo/mambo-4.6.3-r1.ebuild
index ac11ca9e31f6..91701a359ce8 100644
--- a/www-apps/mambo/mambo-4.6.3-r1.ebuild
+++ b/www-apps/mambo/mambo-4.6.3-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.6.3-r1.ebuild,v 1.1 2008/01/27 20:41:44 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.6.3-r1.ebuild,v 1.2 2008/02/03 17:08:49 hollow Exp $
-inherit webapp depend.php
+inherit webapp depend.php depend.apache
MY_PN="${PN/m/M}"
DESCRIPTION="Mambo is a dynamic portal engine and content management system"
@@ -16,13 +16,15 @@ S=${WORKDIR}
IUSE=""
-RDEPEND="
- virtual/httpd-php
- www-servers/apache"
+need_php
+need_apache
pkg_setup () {
webapp_pkg_setup
- require_php_with_use mysql zlib
+ if ! PHPCHECKNODIE="yes" require_php_with_use mysql zlib || \
+ ! PHPCHECKNODIE="yes" require_php_with_any_use apache2 cgi ; then
+ die "Re-install ${PHP_PKG} with mysql zlib and at least one of apache2 or cgi USE flags."
+ fi
}
src_unpack() {