summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/psmisc/psmisc-21.4.ebuild')
-rw-r--r--sys-process/psmisc/psmisc-21.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-process/psmisc/psmisc-21.4.ebuild b/sys-process/psmisc/psmisc-21.4.ebuild
new file mode 100644
index 000000000000..fe17f0425656
--- /dev/null
+++ b/sys-process/psmisc/psmisc-21.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-21.4.ebuild,v 1.1 2005/03/03 16:24:36 ciaranm Exp $
+
+inherit eutils gnuconfig
+
+SELINUX_PATCH="${P}-selinux.diff.bz2"
+
+DESCRIPTION="A set of tools that use the proc filesystem"
+HOMEPAGE="http://psmisc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls selinux"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}
+ use nls || epatch ${FILESDIR}/${P}-no-nls.patch
+
+ epunt_cxx #73632
+}
+
+src_compile() {
+ local myconf=""
+ use selinux && myconf="${myconf} --enable-flask"
+ econf \
+ $(use_enable nls) \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dosym killall /usr/bin/pidof
+
+ # Some packages expect these to use /usr, others to use /
+ dodir /bin
+ mv ${D}/usr/bin/* ${D}/bin/
+ cd ${D}/bin
+ for f in * ; do
+ dosym /bin/${f} /usr/bin/${f}
+ done
+
+ # We use pidof from baselayout.
+ rm -f ${D}/bin/pidof
+ dosym ../sbin/pidof /bin/pidof
+
+ dodoc AUTHORS ChangeLog NEWS README
+}