summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-3.3.1.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-3.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-3.3.1.ebuild b/sys-kernel/ck-sources/ck-sources-3.3.1.ebuild
new file mode 100644
index 000000000000..3bd2f2ff8993
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-3.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ck-sources/ck-sources-3.3.1.ebuild,v 1.1 2012/04/30 09:01:40 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="2"
+K_SECURITY_UNSUPPORTED="1"
+
+inherit kernel-2 versionator
+detect_version
+detect_arch
+
+DESCRIPTION="Con Kolivas' high performance patchset + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/
+ http://users.on.net/~ckolivas/kernel/"
+
+BASE_VERSION="$(get_version_component_range 1-2)"
+CK_VERSION="1"
+
+CK_URI="http://ck.kolivas.org/patches/3.0/${BASE_VERSION}/${BASE_VERSION}-ck${CK_VERSION}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+UNIPATCH_LIST="${DISTDIR}/patch-${BASE_VERSION}-ck${CK_VERSION}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_unpack() {
+ kernel-2_src_unpack
+
+ # Comment out EXTRAVERSION added by CK patch:
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}