summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/traydevice/traydevice-1.6.2-r1.ebuild')
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
index a899fe1c2032..a7276f6b7a32 100644
--- a/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
+++ b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild,v 1.2 2013/05/11 22:24:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild,v 1.3 2013/05/11 22:30:19 ssuominen Exp $
EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_6,2_7} )
inherit distutils-r1
DESCRIPTION="A little desktop application displaying systray icon for UDisks"
@@ -23,9 +22,7 @@ RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
sys-fs/udisks:2"
DEPEND="app-text/docbook2X"
-src_compile() {
- return 0
-}
+src_compile() { :; }
python_install() {
distutils-r1_python_install \
@@ -33,6 +30,9 @@ python_install() {
--install-data=/usr/share/${PN} \
--install-man=/usr/share/man \
--docbook2man=docbook2man.pl
+}
+python_install_all() {
+ distutils-r1_python_install_all
rm -f "${ED}"/usr/share/${PN}/doc/*.txt
}