summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/openmpi/openmpi-1.5.5.ebuild')
-rw-r--r--sys-cluster/openmpi/openmpi-1.5.5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.5.5.ebuild b/sys-cluster/openmpi/openmpi-1.5.5.ebuild
index bb20dba7e115..08d917dcab51 100644
--- a/sys-cluster/openmpi/openmpi-1.5.5.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.5.5.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.5.ebuild,v 1.3 2012/06/25 18:28:11 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.5.5.ebuild,v 1.4 2012/10/14 19:40:20 jlec Exp $
EAPI=4
+
+FORTRAN_NEEDED=fortran
+
inherit eutils fortran-2 multilib flag-o-matic toolchain-funcs versionator
MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
IUSE_OPENMPI_FABRICS="
openmpi_fabrics_dapl
@@ -68,6 +70,8 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
pkg_setup() {
use fortran && fortran-2_pkg_setup
if use mpi-threads; then