summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/palo/palo-1.91.ebuild')
-rw-r--r--sys-boot/palo/palo-1.91.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-boot/palo/palo-1.91.ebuild b/sys-boot/palo/palo-1.91.ebuild
new file mode 100644
index 000000000000..823af8ed9396
--- /dev/null
+++ b/sys-boot/palo/palo-1.91.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.91.ebuild,v 1.1 2013/07/18 15:37:25 jer Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://dev.gentoo.org/~jer/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.18-include.patch \
+ "${FILESDIR}"/${PN}-9999-open.patch \
+ "${FILESDIR}"/${PN}-9999-toolchain.patch
+ sed -i lib/common.h -e '/^#define PALOVERSION/{s|".*"|"'${PV}'"|g}' || die
+ sed -i palo/Makefile -e '/^LDFLAGS=/d' || die
+}
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'MACHINE=parisc iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dohtml README.html
+ dodoc palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ INSOPTIONS="-m 0744" doins "${FILESDIR}"/99palo
+}