summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r3.ebuild')
-rw-r--r--sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r3.ebuild123
1 files changed, 0 insertions, 123 deletions
diff --git a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r3.ebuild b/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r3.ebuild
deleted file mode 100644
index becf43fa13e5..000000000000
--- a/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r3.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pcmcia-cs/pcmcia-cs-3.1.34-r3.ebuild,v 1.2 2002/07/14 19:20:19 aliz Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="PCMCIA tools for Linux"
-SRC_URI="mirror://sourceforge/pcmcia-cs/${P}.tar.gz"
-
-HOMEPAGE="http://pcmcia-cs.sourceforge.net"
-KEYWORDS="x86"
-DEPEND="sys-kernel/linux-headers"
-RDEPEND=""
-SLOT="0"
-LICENSE="GPL"
-
-# check arch for configure
-if [ ${ARCH} = "x86" ] ; then
- MY_ARCH="i386"
-else
- MY_ARCH="ppc"
-fi
-
-# Note: To use this ebuild, you should have the usr/src/linux symlink to
-# the kernel directory that pcmcia-cs should use for configuration.
-
-src_unpack() {
- unpack ${P}.tar.gz
-# patch -p0 < ${FILESDIR}/gentoo-${P}.patch
-
- cd ${S}
- cp Configure Configure.orig
- sed -e 's:usr/man:usr/share/man:g' Configure.orig > Configure
- #man pages will now install into /usr/share/man
-}
-
-src_compile() {
- local myconf
- if [ -n "`use trusted`" ] ; then
- myconf="--trust"
- else
- myconf="--notrust"
- fi
-
- if [ -n "`use apm`" ] ; then
- myconf="$myconf --apm"
- else
- myconf="$myconf --noapm"
- fi
-
- if [ -n "`use pnp`" ] ; then
- myconf="$myconf --pnp"
- else
- myconf="$myconf --nopnp"
- fi
-
- if [ -n "`use nocardbus`" ] ; then
- myconf="$myconf --nocardbus"
- else
- myconf="$myconf --cardbus"
- fi
-
- #use $CFLAGS for user tools, but standard kernel optimizations for the kernel modules (for compatibility)
- ./Configure -n \
- --target=${D} \
- --srctree \
- --kernel=/usr/src/linux \
- --arch="${MY_ARCH}" \
- --uflags="$CFLAGS" \
- --kflags="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer" \
- $myconf || die "failed configuring"
- # nopnp and noapm are important, because without them the pcmcia-cs
- # tools will require a kernel with ISA PnP and/or APM support,
- # which cannot be guaranteed. We need to make sure the tools
- # work *all* the time, not just some of the time.
-
- # The --srctree option tells pcmcia-cs to configure for the kernel in /usr/src/linux
- # rather than the currently-running kernel. It's Gentoo Linux policy to configure for
- # the kernel in /usr/src/linux
- emake all || die "failed compiling"
-}
-
-src_install () {
- make PREFIX=${D} install || die "failed installing"
- cd ${D}
- rm -rf etc/rc*.d
- # remove X
- # this is simply much easier than patching configure or the makefiles
- # not to build them in the first place
- rm -rf usr/X11R6
- # todo: if they are nstalled, move them to /usr
-
- insinto /etc/conf.d
- newins ${FILESDIR}/pcmcia.conf pcmcia
-
- exeinto /etc/pcmcia
- doexe ${FILESDIR}/network
-
- # install our own init script
- exeinto /etc/init.d
- newexe ${FILESDIR}/pcmcia.rc6 pcmcia
- if [ -z "`use build`" ]
- then
- cd ${S}
- # install docs
- dodoc BUGS CHANGES COPYING LICENSE MAINTAINERS README \
- README-2.4 SUPPORTED.CARDS doc/*
- else
- rm -rf ${D}/usr/share/man
- fi
- rm -f ${D}/etc/modules.conf
- rm -rf ${D}/var/lib/pcmcia
-
- # if on ppc set the ppc revised config.opts
- if [ ${ARCH} = "ppc" ] ; then
- insinto /etc/pcmcia
- newins ${FILESDIR}/ppc.config.opts config.opts
- fi
-}
-
-src_postinst() {
- einfo "To avail yourself of the pcmcia-cs drivers, you have to disable the PCMCIA support in the kernel."
- einfo "(Otherwise, you might experience CardServices version mismatch errors)"
-}