summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild')
-rw-r--r--sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild b/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
index a2bc45bb4193..64bf8ee99a80 100644
--- a/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
+++ b/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild,v 1.3 2002/10/04 06:26:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lm_sensors/lm_sensors-2.6.3-r1.ebuild,v 1.4 2002/10/19 04:06:04 vapier Exp $
S="${WORKDIR}/${P}"
DESCRIPTION="Hardware Sensors Monitoring by lm_sensors"
@@ -12,21 +12,19 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="virtual/linux-sources"
+RDEPEND="${DEPEND}"
-src_compile () {
-
+src_compile() {
emake clean all || die "lm_sensors requires the source of a compatible kernel\nversion installed in /usr/src/linux and i2c support built as a modules"
-
}
-src_install () {
+src_install() {
emake DESTDIR=${D} PREFIX=/usr MANDIR=/usr/share/man install || die
exeinto /etc/init.d
newexe ${FILESDIR}/rc_lm_sensors lm_sensors
}
pkg_postinst() {
-
[ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
einfo
@@ -48,5 +46,4 @@ pkg_postinst() {
einfo "kernel, you will need to remerge the lm_sensors package to build"
einfo "new kernel modules."
einfo
-
}