summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/iptables/iptables-1.2.5.ebuild')
-rw-r--r--sys-apps/iptables/iptables-1.2.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/iptables/iptables-1.2.5.ebuild b/sys-apps/iptables/iptables-1.2.5.ebuild
new file mode 100644
index 000000000000..253643b11bed
--- /dev/null
+++ b/sys-apps/iptables/iptables-1.2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/iptables/iptables-1.2.5.ebuild,v 1.1 2002/01/25 21:14:34 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel 2.4 routing and traffic control utilities"
+SRC_URI="http://netfilter.samba.org/files/${P}.tar.bz2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/-O2/${CFLAGS}/g" -e "s:/usr/local::g" Makefile.orig > Makefile
+}
+
+src_compile() {
+ #I had a problem with emake - DR
+ make || die
+}
+
+src_install() {
+ dodir /usr/{lib,share/man/man8,sbin}
+ # iptables and libraries are now installed to /sbin and /lib. Why? So systems
+ # with remote network-mounted /usr filesystems can get their network interfaces
+ # up and running correctly without /usr.
+ make LIBDIR=${D}/lib \
+ BINDIR=${D}/sbin \
+ MANDIR=${D}/usr/share/man \
+ INCDIR=${D}/usr/include \
+ install || die
+ dodoc COPYING KNOWN_BUGS
+}