summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/ginac/ginac-1.4.1.ebuild')
-rw-r--r--sci-mathematics/ginac/ginac-1.4.1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/sci-mathematics/ginac/ginac-1.4.1.ebuild b/sci-mathematics/ginac/ginac-1.4.1.ebuild
deleted file mode 100644
index 4b3d2044c33b..000000000000
--- a/sci-mathematics/ginac/ginac-1.4.1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/ginac/ginac-1.4.1.ebuild,v 1.2 2008/04/01 14:45:11 markusle Exp $
-
-inherit eutils
-
-DESCRIPTION="C++ library and tools for symbolic calculations"
-SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${P}.tar.bz2"
-HOMEPAGE="http://www.ginac.de/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="sci-libs/cln"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( app-doc/doxygen media-gfx/transfig virtual/latex-base )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc4.3.patch
-}
-
-src_compile() {
- econf \
- --docdir=/usr/share/doc/${PF} \
- --htmldir=/usr/share/doc/${PF}/html \
- || die "econf failed"
- emake || die "emake failed"
- if use doc; then
- emake html || die "emake html failed"
- # need to run twice to get the references right (you know, latex)
- # do not add die function at the first one
- make pdf
- emake pdf || die "emake pdf failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README NEWS AUTHORS || die
-}