summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cln/cln-1.3.3.ebuild')
-rw-r--r--sci-libs/cln/cln-1.3.3.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/sci-libs/cln/cln-1.3.3.ebuild b/sci-libs/cln/cln-1.3.3.ebuild
index 8be29628e975..75710a85c0cd 100644
--- a/sci-libs/cln/cln-1.3.3.ebuild
+++ b/sci-libs/cln/cln-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.3.3.ebuild,v 1.1 2013/08/12 20:41:32 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.3.3.ebuild,v 1.2 2013/08/13 15:57:50 bicatali Exp $
EAPI=5
@@ -15,16 +15,16 @@ SLOT="1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="doc examples static-libs"
-DEPEND="dev-libs/gmp
+RDEPEND="dev-libs/gmp"
+DEPEND="${RDEPEND}
doc? ( virtual/latex-base )"
-RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-1.3.2-arm.patch )
pkg_setup() {
- use sparc && append-cppflags "-DNO_ASM"
- use hppa && append-cppflags "-DNO_ASM"
- use arm && append-cppflags "-DNO_ASM"
+ use sparc && append-cppflags -DNO_ASM
+ use hppa && append-cppflags -DNO_ASM
+ use arm && append-cppflags -DNO_ASM
}
src_prepare() {
@@ -36,20 +36,21 @@ src_prepare() {
autotools-utils_src_prepare
}
-src_configure () {
- local myeconfargs=( --datadir="${EPREFIX}"/usr/share/doc/${PF} )
- autotools-utils_src_configure
-}
src_compile() {
autotools-utils_src_compile
- use doc && autotools-utils_src_compile html pdf
+ if use doc; then
+ cd "${BUILD_DIR}"
+ export VARTEXFONTS="${T}/fonts"
+ emake html pdf
+ DOCS=("${BUILD_DIR}/doc/cln.pdf")
+ HTML_DOCS=("${BUILD_DIR}/doc/")
+ fi
}
src_install () {
- use doc && \
- DOCS=("${BUILD_DIR}/doc/cln.pdf") && HTML_DOCS=("${BUILD_DIR}/doc/")
autotools-utils_src_install
if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
insinto /usr/share/doc/${PF}/examples
doins examples/*.cc
fi