summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/spice/spice-3.5.5.ebuild')
-rw-r--r--sci-electronics/spice/spice-3.5.5.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sci-electronics/spice/spice-3.5.5.ebuild b/sci-electronics/spice/spice-3.5.5.ebuild
index 06cdd57cf6cc..3395852ebeb1 100644
--- a/sci-electronics/spice/spice-3.5.5.ebuild
+++ b/sci-electronics/spice/spice-3.5.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/spice-3.5.5.ebuild,v 1.4 2006/05/21 22:20:52 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/spice/spice-3.5.5.ebuild,v 1.5 2007/03/12 18:21:20 calchan Exp $
inherit eutils flag-o-matic
@@ -28,16 +28,18 @@ src_unpack() {
replace-flags -O* -O1
unpack ${A}
- cd ${S}/conf
+ cd ${S}
+ # Avoid re-creating WORKDIR due to stupid mtime
+ touch ..
+
[ -z $EDITOR ] || EDITOR="vim"
-# cp linux{,.orig}
- sed -e "s:termcap:ncurses:g" \
+ sed -i -e "s:termcap:ncurses:g" \
-e "s:joe:${EDITOR}:g" \
-e "s:-O2 -s:${CFLAGS}:g" \
-e "s:SPICE_DIR)/lib:SPICE_DIR)/lib/spice:g" \
-e "s:/usr/local/spice:/usr:g" \
- -i.orig linux
- cd ${S}
+ conf/linux
+ sed -i -e "s:head -1:head -n 1:" util/build
epatch ${FILESDIR}/${P}-gcc-4.1.patch
}
@@ -49,7 +51,7 @@ src_compile() {
src_install() {
cd ${S}
# install binaries
- dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod}
+ dobin obj/bin/{spice3,nutmeg,sconvert,multidec,proc2mod} || die
newbin obj/bin/help spice.help
dosym /usr/bin/spice3 /usr/bin/spice
# install runtime stuff