summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild')
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild
new file mode 100644
index 000000000000..10d413f27f98
--- /dev/null
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/wxmacmolplt/wxmacmolplt-7.3.ebuild,v 1.1 2009/11/01 14:34:22 alexxy Exp $
+
+EAPI="2"
+
+inherit base eutils
+
+DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
+HOMEPAGE="http://www.scl.ameslab.gov/~brett/MacMolPlt/"
+
+SRC_URI="http://www.scl.ameslab.gov/~brett/MacMolPlt/download/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="flash"
+
+DEPEND="x11-libs/wxGTK[opengl]
+ flash? ( media-libs/ming )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with flash ming)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doicon resources/${PN}.png
+ make_desktop_entry ${PN} wxMacMolPlt ${PN}.png "Science;Education"
+}