summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdb2pqr/files/pdb2pqr-1.4.0-automagic.patch')
-rw-r--r--sci-chemistry/pdb2pqr/files/pdb2pqr-1.4.0-automagic.patch95
1 files changed, 95 insertions, 0 deletions
diff --git a/sci-chemistry/pdb2pqr/files/pdb2pqr-1.4.0-automagic.patch b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.4.0-automagic.patch
new file mode 100644
index 000000000000..f837e90390e3
--- /dev/null
+++ b/sci-chemistry/pdb2pqr/files/pdb2pqr-1.4.0-automagic.patch
@@ -0,0 +1,95 @@
+--- configure.ac 2009-04-02 16:53:56.000000000 +0200
++++ configure.ac.new 2009-04-22 11:41:28.000000000 +0200
+@@ -255,38 +255,6 @@
+
+ # Test for Numeric install
+ AC_MSG_CHECKING([whether you defined Numeric or Numpy])
+- if (test -n "${NUMERIC}") ; then
+- AC_MSG_RESULT([yes])
+- NUMERIC_INC=`find ${NUMERIC} -iname "arrayobject.h" | tail -n1`
+- if test "$NUMERIC_INC" = ""; then
+- AC_MSG_ERROR([Please check your NUMERIC path. arrayobject.h cannot be found in ${NUMERIC}])
+- fi
+- NUMERIC_INC=`dirname ${NUMERIC_INC}`
+- NUMERIC_LIB=`find ${NUMERIC} -iname "Numeric.pth" | tail -n1`
+- if test "${NUMERIC_LIB}" = ""; then
+- AC_MSG_ERROR([Please check your NUMERIC path. Numeric.pth cannot be found in ${NUMERIC}])
+- fi
+- NUMERIC_NAME=`cat ${NUMERIC_LIB}`
+- NUMERIC_LIB=`dirname ${NUMERIC_LIB}`
+- NUMERIC_LIB=${NUMERIC_LIB}/${NUMERIC_NAME}
+- if test "${PACKAGE_PATH}" = ""; then
+- PACKAGE_PATH=${NUMERIC_LIB}
+- else
+- PACKAGE_PATH="${PACKAGE_PATH}:${NUMERIC_LIB}"
+- fi
+- PY_NUMERIC="-I${NUMERIC_INC} "
+- PY_CFLAGS="$PY_CFLAGS $PY_NUMERIC"
+- else
+- AC_MSG_RESULT([no])
+- AC_MSG_CHECKING([for Numeric include files])
+- if test -f $PY_PREFIX/include/python$PY_VERSION/Numeric/arrayobject.h; then
+- PY_NUMERIC="-I$PY_PREFIX/include/python$PY_VERSION/Numeric"
+- AC_MSG_RESULT([$PY_NUMERIC])
+- PY_CFLAGS="$PY_CFLAGS $PY_NUMERIC"
+- else
+- AC_MSG_RESULT([no])
+- fi
+- fi
+
+ # If failed, test for numpy
+ AC_MSG_CHECKING([whether you defined numpy])
+@@ -463,23 +431,8 @@
+ echo ZSI is installed
+ else
+ # need to install ZSI
+- echo Installing ZSI. This might take a while...
+- cd contrib/ZSI-2.1-a1
+- if test `whoami` = "root"; then
+- $py_path setup.py install
+- else
+- zsi_install="true"
+- mkdir -p ${prefix}lib/python$PY_VERSION/site-packages
+- export PYTHONPATH=${prefix}lib/python$PY_VERSION/site-packages
+- $py_path setup.py install --prefix=${prefix}
+- if test -d ${prefix}ZSI ; then
+- echo ZSI is installed
+- else
+- cp -r ./build/lib/ZSI ${prefix}ZSI
+- fi
+- PYTHONPATH=""
+- fi
+- cd ../..
++ echo Missing ZSI
++ exit 1
+ fi
+ fi
+
+--- pdb2pka/NEWligand_topology.py 2007-10-12 21:52:40.000000000 +0200
++++ pdb2pka/NEWligand_topology.py.new 2009-04-22 17:01:11.000000000 +0200
+@@ -3,10 +3,7 @@
+ # PC 2005/09/23
+ # Get ligand topologies
+ #
+-try:
+- import Numeric
+-except:
+- import numpy as Numeric
++import numpy as Numeric
+
+ from sets import Set
+ from ligandclean.trial_templates import *
+--- pdb2pka/ligand_topology.py 2008-06-13 16:15:38.000000000 +0200
++++ pdb2pka/ligand_topology.py.new 2009-04-22 17:02:59.000000000 +0200
+@@ -3,10 +3,7 @@
+ # PC 2005/09/23
+ # Get ligand topologies
+ #
+-try:
+- import Numeric
+-except:
+- import numpy as Numeric
++import numpy as Numeric
+
+ from sets import Set
+ from ligandclean.trial_templates import *