summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/gift-openft/gift-openft-0.2.1.4.ebuild')
-rw-r--r--net-p2p/gift-openft/gift-openft-0.2.1.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/gift-openft/gift-openft-0.2.1.4.ebuild b/net-p2p/gift-openft/gift-openft-0.2.1.4.ebuild
new file mode 100644
index 000000000000..3d3ca378f759
--- /dev/null
+++ b/net-p2p/gift-openft/gift-openft-0.2.1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift-openft/gift-openft-0.2.1.4.ebuild,v 1.1 2004/08/10 23:42:15 squinky86 Exp $
+
+IUSE=""
+
+DESCRIPTION="The giFT OpenFT plugin"
+HOMEPAGE="http://gift.sf.net/"
+SRC_URI="mirror://sourceforge/gift/${P}.tar.bz2"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+DEPEND="virtual/libc
+ dev-util/pkgconfig"
+
+RDEPEND=">=net-p2p/gift-0.11.5
+ >=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ econf || die "failed to configure"
+ emake || die "failed to build"
+}
+
+src_install() {
+ einstall giftconfdir=${D}/etc/giFT \
+ plugindir=${D}/usr/lib/giFT \
+ datadir=${D}/usr/share/giFT \
+ giftperldir=${D}/usr/bin \
+ libgiftincdir=${D}/usr/include/libgift || die "Install failed"
+}
+
+pkg_postinst() {
+ einfo "Before you can use the new plugin,"
+ einfo "you should counfigure it with gift-setup command."
+ echo
+ einfo "To run giFT with OpenFT support, run:"
+ einfo "giFT -p /usr/lib/giFT/libOpenFT.so"
+ echo
+ einfo "Alternatively you can add the following line to"
+ einfo "your ~/.giFT/giftd.conf configuration file:"
+ einfo "plugins = OpenFT"
+}