summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/udpxy/udpxy-1.0.21.2.ebuild')
-rw-r--r--net-misc/udpxy/udpxy-1.0.21.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/udpxy/udpxy-1.0.21.2.ebuild b/net-misc/udpxy/udpxy-1.0.21.2.ebuild
new file mode 100644
index 000000000000..051735ef8813
--- /dev/null
+++ b/net-misc/udpxy/udpxy-1.0.21.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udpxy/udpxy-1.0.21.2.ebuild,v 1.1 2012/03/15 14:33:59 pva Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs eutils versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="small-footprint daemon to relay multicast UDP traffic to client's TCP (HTTP) connection"
+HOMEPAGE="http://sourceforge.net/projects/udpxy/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}.${MY_PV}-prod.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-LDFLAGS.patch"
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin udpxy
+ dosym udpxy /usr/bin/udpxrec
+ dodoc README CHANGES
+}