summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libnids/libnids-1.22.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.22.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/libnids/libnids-1.22.ebuild b/net-libs/libnids/libnids-1.22.ebuild
new file mode 100644
index 000000000000..c6c2c011b266
--- /dev/null
+++ b/net-libs/libnids/libnids-1.22.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.22.ebuild,v 1.1 2007/09/30 14:35:44 cedk Exp $
+
+inherit eutils
+
+DESCRIPTION="emulates the IP stack of Linux 2.0.x and offers IP defragmentation, TCP stream assembly and TCP port scan detection."
+HOMEPAGE="http://libnids.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.0-r3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.20-chksum.c-ebx.patch
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install_prefix="${D}" install || die "emake install failed"
+ dodoc CHANGES CREDITS MISC README
+ dodoc doc/*
+}