summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild')
-rw-r--r--net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild b/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild
new file mode 100644
index 000000000000..b203401e0ff5
--- /dev/null
+++ b/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpstat/tcpstat-1.5-r2.ebuild,v 1.1 2014/06/30 13:04:05 jer Exp $
+
+EAPI=5
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Reports network interface statistics"
+SRC_URI="http://www.frenchfries.net/paul/tcpstat/${P}.tar.gz"
+HOMEPAGE="http://www.frenchfries.net/paul/tcpstat/"
+
+DEPEND="net-libs/libpcap"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ipv6"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-db.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -Wall -Wextra
+ econf $(use_enable ipv6)
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README doc/Tips_and_Tricks.txt )
+
+src_install() {
+ default
+ dobin src/{catpcap,packetdump}
+ newdoc src/README README.src
+}