summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/tcpreplay/tcpreplay-2.3.2.ebuild')
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-2.3.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/tcpreplay-2.3.2.ebuild b/net-analyzer/tcpreplay/tcpreplay-2.3.2.ebuild
new file mode 100644
index 000000000000..bc37fe2aa271
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-2.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpreplay/tcpreplay-2.3.2.ebuild,v 1.1 2005/01/29 20:46:02 dragonheart Exp $
+
+DESCRIPTION="replay saved tcpdump or snoop files at arbitrary speeds"
+HOMEPAGE="http://tcpreplay.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug"
+
+DEPEND=">=net-libs/libnet-1.1.1
+ virtual/libpcap
+ net-analyzer/tcpdump"
+
+src_compile() {
+ econf \
+ $(use_with debug) \
+ || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ # This would work if src_test was run as root when FEATURES didn't
+ # have user priv.
+
+ #if hasq userpriv "${FEATURES}"; then
+ ewarn "Some tested disabled due to FEATURES=userpriv"
+ ewarn "For a full test as root - make -C ${S}/test"
+ if ! make -C test tcpprep; then
+ cat test/test.log
+ die "self test failed"
+ fi
+ #else
+ # if ! make test; then
+ # cat test/test.log
+ # die "self test failed"
+ # fi
+ #fi
+
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ MAN8DIR=${D}/usr/share/man/man8 \
+ MAN1DIR=${D}/usr/share/man/man1 \
+ install \
+ || die "install failed"
+ dodoc Docs/*
+}