summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/gxine/gxine-0.3.1.ebuild')
-rw-r--r--media-video/gxine/gxine-0.3.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-video/gxine/gxine-0.3.1.ebuild b/media-video/gxine/gxine-0.3.1.ebuild
new file mode 100644
index 000000000000..8f46e3ed8ef5
--- /dev/null
+++ b/media-video/gxine/gxine-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/gxine/gxine-0.3.1.ebuild,v 1.1 2003/03/10 21:20:57 agenkin Exp $
+
+DESCRIPTION="GTK+ Front-End for libxine"
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_beta6
+ >=x11-libs/gtk+-2.0.0
+ app-misc/lirc
+ X? ( virtual/x11 )
+ gnome? ( gnome-base/ORBit )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X gnome nls"
+
+SLOT="0"
+KEYWORDS="x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}