summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-tv/xdtv/xdtv-2.2.0.ebuild')
-rw-r--r--media-tv/xdtv/xdtv-2.2.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/media-tv/xdtv/xdtv-2.2.0.ebuild b/media-tv/xdtv/xdtv-2.2.0.ebuild
index 79d65d655077..9a5dfa319bfe 100644
--- a/media-tv/xdtv/xdtv-2.2.0.ebuild
+++ b/media-tv/xdtv/xdtv-2.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/xdtv/xdtv-2.2.0.ebuild,v 1.5 2005/07/10 13:19:40 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/xdtv/xdtv-2.2.0.ebuild,v 1.6 2005/07/13 21:45:05 zzam Exp $
-inherit font multilib flag-o-matic
+inherit font multilib
IUSE="alsa jpeg encode ffmpeg xvid lirc xinerama divx4linux
neXt Xaw3d mmx zvbi aqua_theme xv debug dvb"
@@ -75,7 +75,10 @@ RDEPEND="virtual/x11
alsa? ( >=media-libs/alsa-lib-0.9 )"
DEPEND="${RDEPEND}
- dvb? ( =media-tv/linuxtv-dvb-headers-3* )"
+ dvb? ( ||(
+ >=sys-kernel/linux-headers-2.6.11-r2
+ media-tv/linuxtv-dvb
+ ) )"
FONT_S="${S}/font"
FONT_SUFFIX="pcf.gz"
@@ -136,9 +139,6 @@ src_compile() {
( use mmx || use amd64 ) && myconf="${myconf} --enable-mmx" || \
myconf="${myconf} --disable-mmx"
- # linux-dvb headers are installed in /usr/include/dvb to avoid collision-protect
- use dvb && CPPFLAGS="${CPPFLAGS} -I/usr/include/dvb"
-
econf ${xawconf} \
$(use_enable divx4linux) \
$(use_enable alsa) \
@@ -155,7 +155,6 @@ src_compile() {
--enable-pixmaps \
--disable-cpu-detection \
${myconf} \
- CPPFLAGS="${CPPFLAGS}" \
|| die "Configuration failed."
emake OPT="${CFLAGS}" PERF_FLAGS="${CFLAGS}" || die "Compilation failed."