summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/amarok/amarok-1.2.4.ebuild')
-rw-r--r--media-sound/amarok/amarok-1.2.4.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-sound/amarok/amarok-1.2.4.ebuild b/media-sound/amarok/amarok-1.2.4.ebuild
index 11bbea9ba023..a536a0146f43 100644
--- a/media-sound/amarok/amarok-1.2.4.ebuild
+++ b/media-sound/amarok/amarok-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.2.4.ebuild,v 1.1 2005/05/21 17:34:29 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.2.4.ebuild,v 1.2 2005/06/22 17:46:04 hanno Exp $
inherit kde eutils
@@ -55,6 +55,11 @@ pkg_setup() {
kde_pkg_setup
}
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/amarok-gcc4.gz
+}
+
src_compile() {
# amarok does not respect kde coding standards, and makes a lot of
# assuptions regarding its installation directory. For this reason,