summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl-sound/sdl-sound-1.0.1.ebuild')
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.1.ebuild36
1 files changed, 20 insertions, 16 deletions
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
index 46ce71c9b1b3..bc52e6b1aef0 100644
--- a/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
+++ b/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
@@ -1,51 +1,55 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild,v 1.2 2003/10/15 04:36:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild,v 1.3 2003/11/04 08:21:42 vapier Exp $
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
DESCRIPTION="A library that handles the decoding of sound file formats"
-SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
HOMEPAGE="http://icculus.org/SDL_sound/"
+SRC_URI="http://icculus.org/SDL_sound/downloads/${MY_P}.tar.gz"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
LICENSE="LGPL-2.1"
SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="flac mikmod oggvorbis speex physfs"
DEPEND=">=media-libs/libsdl-1.2
>=media-libs/smpeg-0.4.4-r1
flac? ( media-libs/flac )
mikmod? ( >=media-libs/libmikmod-3.1.9 )
- oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )"
-
-IUSE="flac mikmod oggvorbis"
+ oggvorbis? ( >=media-libs/libvorbis-1.0_beta4 )
+ speex? ( media-libs/speex
+ media-libs/libogg )
+ physfs? ( dev-games/physfs )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/gcc331.patch
rm aclocal.m4
-}
-src_compile() {
# the patch above plus this overkill ripped off the bootstrap scipt from
# the sdl_sound CVS to address bug 31163 until the next release.
- aclocal
- libtoolize --automake --copy --force
- autoheader
- automake --foreign --add-missing --copy
- autoconf
+ aclocal || die "aclocal failed"
+ libtoolize --automake --copy --force || die "libtoolize failed"
+ autoheader || die "autoheader failed"
+ automake --foreign --add-missing --copy || die "automake failed"
+ autoconf || die "autoconf failed"
+}
+src_compile() {
econf \
`use_enable flac` \
`use_enable mikmod` \
`use_enable oggvorbis ogg` \
- --enable-midi || die
-
+ `use_enable physfs` \
+ `use_enable speex` \
+ --enable-midi \
+ || die
emake || die "emake failed"
}
src_install() {
einstall || die
- dodoc CHANGELOG CREDITS INSTALL README TODO || die "dodoc failed"
+ dodoc CHANGELOG CREDITS INSTALL README TODO
}