summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/superkaramba/superkaramba-4.8.4.ebuild')
-rw-r--r--kde-base/superkaramba/superkaramba-4.8.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/superkaramba/superkaramba-4.8.4.ebuild b/kde-base/superkaramba/superkaramba-4.8.4.ebuild
new file mode 100644
index 000000000000..3caba54e1f3a
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.8.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.8.4.ebuild,v 1.1 2012/06/21 21:54:39 dilfridge Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+inherit python kde4-base
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug python"
+
+DEPEND="
+ media-libs/qimageblitz
+ python? ( $(add_kdebase_dep pykde4) )
+"
+RDEPEND="${DEPEND}
+ python? ( $(add_kdebase_dep krosspython) )
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ )
+
+ kde4-base_src_configure
+}