summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/marble/marble-4.9.0.ebuild')
-rw-r--r--kde-base/marble/marble-4.9.0.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/kde-base/marble/marble-4.9.0.ebuild b/kde-base/marble/marble-4.9.0.ebuild
index 88acf3d174c4..2139bc49c8fc 100644
--- a/kde-base/marble/marble-4.9.0.ebuild
+++ b/kde-base/marble/marble-4.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/marble-4.9.0.ebuild,v 1.1 2012/08/01 22:17:31 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/marble/marble-4.9.0.ebuild,v 1.2 2012/08/02 16:55:46 kensington Exp $
EAPI=4
@@ -13,15 +13,18 @@ inherit kde4-base python
DESCRIPTION="Generic geographical map widget"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug designer-plugin gps +kde plasma python"
+IUSE="debug designer-plugin gps +kde plasma python test"
-# tests fail / segfault. Last checked for 4.2.88
-# RESTRICT=test
+# tests fail / segfault. Last checked for 4.9.0
+RESTRICT="test"
-DEPEND="
+RDEPEND="
x11-libs/qt-core:4
+ x11-libs/qt-declarative:4
x11-libs/qt-gui:4[dbus]
x11-libs/qt-script:4
+ x11-libs/qt-sql:4
+ x11-libs/qt-svg:4
x11-libs/qt-webkit:4
gps? ( >=sci-geosciences/gpsd-2.95[qt4] )
python? (
@@ -29,10 +32,12 @@ DEPEND="
kde? ( $(add_kdebase_dep pykde4) )
)
"
-RDEPEND="${DEPEND}
+DEPEND="
+ ${RDEPEND}
+ test? ( x11-libs/qt-test:4 )
"
# the qt dependencies are needed because with USE=-kde nothing is pulled in
-# by default... bug 414165
+# by default... bugs 414165 & 414165
REQUIRED_USE="
plasma? ( kde )
@@ -60,6 +65,7 @@ src_configure() {
$(cmake-utils_use_with gps libgps)
$(cmake-utils_use !kde QTONLY)
$(cmake-utils_use_with plasma)
+ -DBUILD_MARBLE_TESTS=OFF
-DWITH_liblocation=0
$(use kde && cmake-utils_use_with python PyKDE4)
)
@@ -71,6 +77,9 @@ src_test() {
if use kde; then
elog "Marble tests can only be run in the qt-only version"
else
+ local mycmakeargs=(
+ -DBUILD_MARBLE_TESTS=ON
+ )
kde4-base_src_test
fi
}